summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/vlan/vlan_1.9.bb')
-rw-r--r--meta-networking/recipes-connectivity/vlan/vlan_1.9.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
new file mode 100644
index 000000000..2c4f1577e
--- /dev/null
+++ b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
@@ -0,0 +1,25 @@
1SUMMARY = "VLAN provides vconfig utility"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://vconfig.c;md5=293ef69c4e88434d37a5ee577a5288cb"
4
5SRC_URI = "http://${BPN}.sourcearchive.com/downloads/${PV}-3ubuntu9/${BPN}_${PV}.orig.tar.gz"
6
7SRC_URI[md5sum] = "5f0c6060b33956fb16e11a15467dd394"
8SRC_URI[sha256sum] = "3b8f0a1bf0d3642764e5f646e1f3bbc8b1eeec474a77392d9aeb4868842b4cca"
9
10S = "${WORKDIR}/${BPN}"
11
12# comment out MakeInclude in Makefile which sets build environment
13do_configure_append () {
14 sed -i 's/^ include/#^include/' ${S}/Makefile
15}
16
17# ignore strip to avoid yocto errors in stripping
18do_compile () {
19 oe_runmake PLATFORM=ARM 'STRIP=echo' all
20}
21
22do_install () {
23 install -d ${D}/${exec_prefix}/bin
24 cp ${S}/vconfig ${D}/${exec_prefix}/bin
25}