summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch')
-rw-r--r--meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch b/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch
new file mode 100644
index 000000000..f25a02cd8
--- /dev/null
+++ b/meta-networking/recipes-connectivity/sethdlc/files/sethdlc-fix-host-contamination.patch
@@ -0,0 +1,42 @@
1From 9a9137c3df5309ac359737d6ebd67fb4ff5f3cf2 Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Mon, 24 Nov 2014 22:05:18 -0500
4Subject: [PATCH] sethdlc: fix host contamination
5
6Clean INCLUDES to fix the host contamination errors:
7
8 In file included from /usr/src/linux/include/linux/posix_types.h:47:0,
9 from /usr/src/linux/include/linux/types.h:17,
10 from /usr/src/linux/include/linux/if.h:22,
11 from sethdlc.c:23:
12 /usr/src/linux/include/asm-generic/posix_types.h:91:3: \
13 error: conflicting types for '__kernel_fsid_t'
14 } __kernel_fsid_t;
15 ^
16 .../tmp/sysroots/qemumips/usr/include/asm/posix_types.h:26:3: \
17 note: previous declaration of '__kernel_fsid_t' was here
18 } __kernel_fsid_t;
19 ^
20
21Upstream-Status: Pending
22
23Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
24---
25 Makefile | 2 +-
26 1 file changed, 1 insertion(+), 1 deletion(-)
27
28diff --git a/Makefile b/Makefile
29index 0492f2b..97dec22 100644
30--- a/Makefile
31+++ b/Makefile
32@@ -1,6 +1,6 @@
33 CC = gcc
34 CFLAGS = -O2 -Wall -W -Wno-long-long -pipe
35-INCLUDES = -I/usr/src/linux/include -I/usr/src/linux-2.6/include
36+INCLUDES =
37
38 all: sethdlc
39
40--
411.7.9.5
42