summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb')
-rw-r--r--meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb b/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb
new file mode 100644
index 000000000..7a496b7c5
--- /dev/null
+++ b/meta-networking/recipes-connectivity/polarssl/polarssl_1.3.8.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "PolarSSL is a lean open source crypto library \
3for providing SSL and TLS support in your programs. It offers \
4an intuitive API and documented header files, so you can actually \
5understand what the code does. It features: \
6 \
7 - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
8 Camellia and XTEA \
9 - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
10 - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
11 - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
12 ECDSA and ECDH \
13 - SSL v3 and TLS 1.0, 1.1 and 1.2 \
14 - Abstraction layers for ciphers, hashes, public key operations, \
15 platform abstraction and threading \
16"
17
18HOMEPAGE = "https://polarssl.org"
19BUGTRACKER = "https://github.com/polarssl/polarssl/issues"
20
21LICENSE = "GPLv2"
22LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
23
24SECTION = "net"
25
26SRC_URI = "https://polarssl.org/download/polarssl-${PV}-gpl.tgz"
27
28SRC_URI[md5sum] = "d1a2b4f21727e888f143414d2e3144e6"
29SRC_URI[sha256sum] = "318171db41335cacbb5b0047c94f1faf91442ab70a223b5223436703c9406ff1"
30
31DEPENDS = "openssl"
32RDEPENDS_${PN} += "libcrypto"
33EXTRA_OECMAKE = "-DUSE_SHARED_POLARSSL_LIBRARY=on"
34
35inherit cmake