summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch')
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch b/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch
deleted file mode 100644
index ffaff48dd..000000000
--- a/meta-networking/recipes-connectivity/openthread/ot-daemon/mbedtls.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1mbedtls: Disable documentation warning as error with clang
2
3There are shortcomings with doxygen info which clang-15+ flags, dont
4treat them as errors
5
6Remove unused variable
7
8Fixes
9library/bignum.c:1395:29: error: variable 't' set but not used [-Werror,-Wunused-but-set-variable]
10
11Upstream-Status: Pending
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13--- a/third_party/mbedtls/repo/library/bignum.c
14+++ b/third_party/mbedtls/repo/library/bignum.c
15@@ -1544,7 +1544,7 @@ __attribute__ ((noinline))
16 #endif
17 void mpi_mul_hlp( size_t i, mbedtls_mpi_uint *s, mbedtls_mpi_uint *d, mbedtls_mpi_uint b )
18 {
19- mbedtls_mpi_uint c = 0, t = 0;
20+ mbedtls_mpi_uint c = 0, t __attribute__ ((unused)) = 0;
21
22 #if defined(MULADDC_HUIT)
23 for( ; i >= 8; i -= 8 )
24--- a/third_party/mbedtls/repo/CMakeLists.txt
25+++ b/third_party/mbedtls/repo/CMakeLists.txt
26@@ -192,7 +192,7 @@ if(CMAKE_COMPILER_IS_GNU)
27 endif(CMAKE_COMPILER_IS_GNU)
28
29 if(CMAKE_COMPILER_IS_CLANG)
30- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wwrite-strings -Wpointer-arith -Wimplicit-fallthrough -Wshadow -Wvla")
31+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Wextra -Wwrite-strings -Wpointer-arith -Wimplicit-fallthrough -Wshadow -Wvla -Wno-error=documentation")
32 set(CMAKE_C_FLAGS_RELEASE "-O2")
33 set(CMAKE_C_FLAGS_DEBUG "-O0 -g3")
34 set(CMAKE_C_FLAGS_COVERAGE "-O0 -g3 --coverage")