summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb')
-rw-r--r--meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb b/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
index d7be1cd71..ec930de27 100644
--- a/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
+++ b/meta-networking/recipes-connectivity/openthread/ot-br-posix_git.bb
@@ -29,11 +29,15 @@ inherit pkgconfig cmake systemd
29# for (uint8_t i = 0;; i++) 29# for (uint8_t i = 0;; i++)
30CXXFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare -Wno-error=unused-but-set-variable" 30CXXFLAGS:append:libc-musl:toolchain-clang = " -Wno-error=sign-compare -Wno-error=unused-but-set-variable"
31 31
32LDFLAGS:append:riscv32 = " -latomic"
33
32EXTRA_OECMAKE = "-DBUILD_TESTING=OFF \ 34EXTRA_OECMAKE = "-DBUILD_TESTING=OFF \
33 -DOTBR_DBUS=ON \ 35 -DOTBR_DBUS=ON \
34 -DOTBR_REST=ON \ 36 -DOTBR_REST=ON \
35 -DOTBR_WEB=OFF \ 37 -DOTBR_WEB=OFF \
36 -DCMAKE_LIBRARY_PATH=${libdir} \ 38 -DCMAKE_LIBRARY_PATH=${libdir} \
39 -DOT_POSIX_PRODUCT_CONFIG=${sysconfdir}/openthread.conf.example \
40 -DOT_POSIX_FACTORY_CONFIG=${sysconfdir}/openthread.conf.example \
37 -DOTBR_MDNS=avahi \ 41 -DOTBR_MDNS=avahi \
38 -DOTBR_BACKBONE_ROUTER=ON \ 42 -DOTBR_BACKBONE_ROUTER=ON \
39 -DOTBR_BORDER_ROUTING=ON \ 43 -DOTBR_BORDER_ROUTING=ON \
@@ -63,3 +67,7 @@ RCONFLICTS:${PN} = "ot-daemon"
63 67
64FILES:${PN} += "${systemd_unitdir}/*" 68FILES:${PN} += "${systemd_unitdir}/*"
65FILES:${PN} += "${datadir}/*" 69FILES:${PN} += "${datadir}/*"
70
71# http://errors.yoctoproject.org/Errors/Details/766903/
72# git/third_party/openthread/repo/src/core/border_router/routing_manager.hpp:615:11: error: 'ot::BorderRouter::RoutingManager::DiscoveredPrefixTable' declared with greater visibility than the type of its field 'ot::BorderRouter::RoutingManager::DiscoveredPrefixTable::mEntryTimer' [-Werror=attributes]
73CXXFLAGS += "-Wno-error=attributes"