summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb')
-rw-r--r--meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb b/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb
new file mode 100644
index 000000000..fa6b43ace
--- /dev/null
+++ b/meta-networking/recipes-connectivity/nanomsg/nanomsg_1.1.4.bb
@@ -0,0 +1,28 @@
1SUMMARY = "nanomsg socket library"
2DESCRIPTION = "nanomsg is a socket library that provides several common \
3communication patterns. It aims to make the networking layer fast, scalable, \
4and easy to use. Implemented in C, it works on a wide range of operating \
5systems with no further dependencies."
6HOMEPAGE = "https://nanomsg.org/"
7LICENSE = "MIT-X"
8LIC_FILES_CHKSUM = "file://COPYING;md5=587b3fd7fd291e418ff4d2b8f3904755"
9
10SECTION = "libs/networking"
11
12SRC_URI = "git://github.com/nanomsg/nanomsg.git;protocol=https"
13SRCREV = "e7f8a751316b942d8962cd0232c2d606c1d9a9db"
14
15S = "${WORKDIR}/git"
16
17inherit cmake pkgconfig
18
19# nanomsg documentation generation requires asciidoctor,
20# not asciidoc, and currently there's no asciidoctor-native
21# recipe anywhere in openembedded-core or meta-openembedded
22EXTRA_OECMAKE = " -DNN_ENABLE_DOC=OFF "
23
24# we don't want nanomsg-tools to be renamed to libnanomsg-tools
25DEBIAN_NOAUTONAME_${PN}-tools = "1"
26
27PACKAGES =+ "${PN}-tools"
28FILES_${PN}-tools = "${bindir}/*"