summaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.1.bb')
-rw-r--r--meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.1.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.1.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.1.bb
new file mode 100644
index 000000000..62c3add2a
--- /dev/null
+++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_3.6.1.bb
@@ -0,0 +1,81 @@
1SUMMARY = "Lightweight crypto and SSL/TLS library"
2DESCRIPTION = "mbedtls is a lean open source crypto library \
3for providing SSL and TLS support in your programs. It offers \
4an intuitive API and documented header files, so you can actually \
5understand what the code does. It features: \
6 \
7 - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \
8 Camellia and XTEA \
9 - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \
10 - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \
11 - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \
12 ECDSA and ECDH \
13 - SSL v3 and TLS 1.0, 1.1 and 1.2 \
14 - Abstraction layers for ciphers, hashes, public key operations, \
15 platform abstraction and threading \
16"
17
18HOMEPAGE = "https://tls.mbed.org/"
19
20LICENSE = "Apache-2.0 | GPL-2.0-or-later"
21LIC_FILES_CHKSUM = "file://LICENSE;md5=379d5819937a6c2f1ef1630d341e026d"
22
23SECTION = "libs"
24
25S = "${WORKDIR}/git"
26SRC_URI = "git://github.com/Mbed-TLS/mbedtls.git;protocol=https;branch=mbedtls-3.6 \
27 git://github.com/Mbed-TLS/mbedtls-framework.git;protocol=https;branch=main;destsuffix=git/framework;name=framework \
28 file://run-ptest"
29
30SRCREV = "71c569d44bf3a8bd53d874c81ee8ac644dd6e9e3"
31SRCREV_framework = "94599c0e3b5036e086446a51a3f79640f70f22f6"
32SRCREV_FORMAT .= "_framework"
33
34UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
35
36inherit cmake update-alternatives ptest
37
38PACKAGECONFIG ??= "shared-libs programs ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
39PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF"
40PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF"
41PACKAGECONFIG[werror] = "-DMBEDTLS_FATAL_WARNINGS=ON,-DMBEDTLS_FATAL_WARNINGS=OFF"
42# Make X.509 and TLS calls use PSA
43# https://github.com/Mbed-TLS/mbedtls/blob/development/docs/use-psa-crypto.md
44PACKAGECONFIG[psa] = ""
45PACKAGECONFIG[tests] = "-DENABLE_TESTING=ON,-DENABLE_TESTING=OFF"
46
47# For now the only way to enable PSA is to explicitly pass a -D via CFLAGS
48CFLAGS:append = "${@bb.utils.contains('PACKAGECONFIG', 'psa', ' -DMBEDTLS_USE_PSA_CRYPTO', '', d)}"
49
50PROVIDES += "polarssl"
51RPROVIDES:${PN} = "polarssl"
52
53PACKAGES =+ "${PN}-programs"
54FILES:${PN}-programs = "${bindir}/"
55
56ALTERNATIVE:${PN}-programs = "${@bb.utils.contains('PACKAGECONFIG', 'programs', 'hello', '', d)}"
57ALTERNATIVE_LINK_NAME[hello] = "${bindir}/hello"
58
59BBCLASSEXTEND = "native nativesdk"
60
61CVE_PRODUCT = "mbed_tls"
62
63# Strip host paths from autogenerated test files
64do_compile:append() {
65 sed -i 's+${S}/++g' ${B}/tests/*.c 2>/dev/null || :
66 sed -i 's+${B}/++g' ${B}/tests/*.c 2>/dev/null || :
67}
68
69# Export source files/headers needed by Arm Trusted Firmware
70sysroot_stage_all:append() {
71 sysroot_stage_dir "${S}/library" "${SYSROOT_DESTDIR}/usr/share/mbedtls-source/library"
72 sysroot_stage_dir "${S}/include" "${SYSROOT_DESTDIR}/usr/share/mbedtls-source/include"
73}
74
75do_install_ptest () {
76 install -d ${D}${PTEST_PATH}/tests
77 install -d ${D}${PTEST_PATH}/framework
78 cp -f ${B}/tests/test_suite_* ${D}${PTEST_PATH}/tests/
79 find ${D}${PTEST_PATH}/tests/ -type f -name "*.c" -delete
80 cp -fR ${S}/framework/data_files ${D}${PTEST_PATH}/framework/
81}