diff options
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls/mbedtls_2.24.0.bb')
-rw-r--r-- | meta-networking/recipes-connectivity/mbedtls/mbedtls_2.24.0.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.24.0.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.24.0.bb new file mode 100644 index 000000000..e3a016956 --- /dev/null +++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.24.0.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Lightweight crypto and SSL/TLS library" | ||
2 | DESCRIPTION = "mbedtls is a lean open source crypto library \ | ||
3 | for providing SSL and TLS support in your programs. It offers \ | ||
4 | an intuitive API and documented header files, so you can actually \ | ||
5 | understand what the code does. It features: \ | ||
6 | \ | ||
7 | - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ | ||
8 | Camellia and XTEA \ | ||
9 | - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ | ||
10 | - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ | ||
11 | - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ | ||
12 | ECDSA and ECDH \ | ||
13 | - SSL v3 and TLS 1.0, 1.1 and 1.2 \ | ||
14 | - Abstraction layers for ciphers, hashes, public key operations, \ | ||
15 | platform abstraction and threading \ | ||
16 | " | ||
17 | |||
18 | HOMEPAGE = "https://tls.mbed.org/" | ||
19 | |||
20 | LICENSE = "Apache-2.0" | ||
21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57" | ||
22 | |||
23 | SECTION = "libs" | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | SRCREV = "523f0554b6cdc7ace5d360885c3f5bbcc73ec0e8" | ||
27 | SRC_URI = "git://github.com/ARMmbed/mbedtls.git;protocol=https;branch=development \ | ||
28 | file://fix-incorrect-EOF-check-in-ssl_context_info.patch \ | ||
29 | " | ||
30 | |||
31 | inherit cmake | ||
32 | |||
33 | PACKAGECONFIG ??= "shared-libs programs" | ||
34 | PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-DUSE_SHARED_MBEDTLS_LIBRARY=OFF" | ||
35 | PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF" | ||
36 | |||
37 | EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}" | ||
38 | |||
39 | PROVIDES += "polarssl" | ||
40 | RPROVIDES_${PN} = "polarssl" | ||
41 | |||
42 | PACKAGES =+ "${PN}-programs" | ||
43 | FILES_${PN}-programs = "${bindir}/" | ||
44 | |||
45 | BBCLASSEXTEND = "native nativesdk" | ||