diff options
Diffstat (limited to 'meta-networking/recipes-connectivity/mbedtls/mbedtls_2.11.0.bb')
-rw-r--r-- | meta-networking/recipes-connectivity/mbedtls/mbedtls_2.11.0.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.11.0.bb b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.11.0.bb new file mode 100644 index 000000000..71b1f8023 --- /dev/null +++ b/meta-networking/recipes-connectivity/mbedtls/mbedtls_2.11.0.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SUMMARY = "Lightweight crypto and SSL/TLS library" | ||
2 | DESCRIPTION = "mbedtls is a lean open source crypto library \ | ||
3 | for providing SSL and TLS support in your programs. It offers \ | ||
4 | an intuitive API and documented header files, so you can actually \ | ||
5 | understand what the code does. It features: \ | ||
6 | \ | ||
7 | - Symmetric algorithms, like AES, Blowfish, Triple-DES, DES, ARC4, \ | ||
8 | Camellia and XTEA \ | ||
9 | - Hash algorithms, like SHA-1, SHA-2, RIPEMD-160 and MD5 \ | ||
10 | - Entropy pool and random generators, like CTR-DRBG and HMAC-DRBG \ | ||
11 | - Public key algorithms, like RSA, Elliptic Curves, Diffie-Hellman, \ | ||
12 | ECDSA and ECDH \ | ||
13 | - SSL v3 and TLS 1.0, 1.1 and 1.2 \ | ||
14 | - Abstraction layers for ciphers, hashes, public key operations, \ | ||
15 | platform abstraction and threading \ | ||
16 | " | ||
17 | |||
18 | HOMEPAGE = "https://tls.mbed.org/" | ||
19 | |||
20 | LICENSE = "Apache-2.0" | ||
21 | LIC_FILES_CHKSUM = "file://LICENSE;md5=302d50a6369f5f22efdb674db908167a" | ||
22 | |||
23 | SECTION = "libs" | ||
24 | |||
25 | SRC_URI = "https://tls.mbed.org/download/mbedtls-${PV}-apache.tgz" | ||
26 | |||
27 | SRC_URI[md5sum] = "3b133b9b4cf0ccf3ac1c91436771bfa5" | ||
28 | SRC_URI[sha256sum] = "2a87061ad770e6d019b3b9cd27ea42a58bd0affccc4c6bfe4f5f0eee9ebf8aa8" | ||
29 | |||
30 | inherit cmake | ||
31 | |||
32 | PACKAGECONFIG ??= "shared-libs programs" | ||
33 | PACKAGECONFIG[shared-libs] = "-DUSE_SHARED_MBEDTLS_LIBRARY=ON,-USE_SHARED_MBEDTLS_LIBRARY=OFF" | ||
34 | PACKAGECONFIG[programs] = "-DENABLE_PROGRAMS=ON,-DENABLE_PROGRAMS=OFF" | ||
35 | |||
36 | EXTRA_OECMAKE = "-DENABLE_TESTING=OFF -DLIB_INSTALL_DIR:STRING=${libdir}" | ||
37 | |||
38 | PROVIDES += "polarssl" | ||
39 | RPROVIDES_${PN} = "polarssl" | ||
40 | |||
41 | PACKAGES =+ "${PN}-programs" | ||
42 | FILES_${PN}-programs = "${bindir}/" | ||