summaryrefslogtreecommitdiffstats
path: root/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda_4.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda_4.15.bb')
-rw-r--r--meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda_4.15.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda_4.15.bb b/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda_4.15.bb
new file mode 100644
index 000000000..dd2df3222
--- /dev/null
+++ b/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda_4.15.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Wireless Central Regulatory Domain Agent"
2HOMEPAGE = "http://wireless.kernel.org/en/developers/Regulatory/CRDA"
3SECTION = "net"
4LICENSE = "copyleft-next-0.3.0"
5LIC_FILES_CHKSUM = "file://copyleft-next-0.3.0;md5=8743a2c359037d4d329a31e79eabeffe"
6
7DEPENDS = "python3-m2crypto-native libnl libgcrypt"
8
9SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/mcgrof/crda.git;branch=master \
10 file://do-not-run-ldconfig-if-destdir-is-set.patch \
11 file://fix-linking-of-libraries-used-by-reglib.patch \
12 file://0001-Makefile-respect-LDFLAGS-for-libreg.patch \
13 file://use-target-word-size-instead-of-host-s.patch \
14 file://fix-issues-when-USE_OPENSSL-1.patch \
15 file://crda-4.14-python-3.patch \
16 file://0001-Make-alpha2-to-be-3-characters-long.patch \
17 file://0001-reglib-Remove-unused-variables.patch \
18"
19SRCREV = "6aeea99ceeec85dd7a9202ee39c7f3b2a8f5195d"
20
21S = "${WORKDIR}/git"
22
23inherit pkgconfig python3-dir python3native siteinfo
24
25# Recursive make problem
26EXTRA_OEMAKE = "MAKEFLAGS= DESTDIR=${D} LIBDIR=${libdir}/crda LDLIBREG='-Wl,-rpath,${libdir}/crda -lreg' \
27 UDEV_RULE_DIR=${nonarch_base_libdir}/udev/rules.d/"
28TARGET_BITS = "${SITEINFO_BITS}"
29export TARGET_BITS
30
31do_compile() {
32 oe_runmake all_noverify
33}
34
35do_install() {
36 oe_runmake SBINDIR=${sbindir}/ install
37}
38
39RDEPENDS:${PN} = "udev wireless-regdb"