summaryrefslogtreecommitdiffstats
path: root/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda/make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda/make.patch')
-rw-r--r--meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda/make.patch25
1 files changed, 0 insertions, 25 deletions
diff --git a/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda/make.patch b/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda/make.patch
deleted file mode 100644
index 0b737852c..000000000
--- a/meta-networking/dynamic-layers/meta-python/recipes-connectivity/crda/crda/make.patch
+++ /dev/null
@@ -1,25 +0,0 @@
1These headers are not related to any Make rule but they do appear in
2compiling of libreg.so, specifying .h files in compiler cmdline is flagged
3as error by clang
4
5| clang-4.0: error: cannot specify -o when generating multiple output files
6| make: *** [libreg.so] Error 1
7
8This is how we see headers in cmdline
9-O2 -fpic -std=gnu
1099 -Wall -Werror -pedantic -Wall -g -DUSE_GCRYPT -DCONFIG_LIBNL30 `pkg-config --cflags libnl-3.0` -o libreg.so -shared -Wl,-soname,libreg.so
11regdb.h reglib.h reglib.c keys-gcrypt.c -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -L ./ -lm -lgcrypt
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14
15--- a/Makefile.kk 2016-11-15 04:54:53.338670000 +0000
16+++ a/Makefile 2016-11-15 04:55:07.718670000 +0000
17@@ -114,7 +114,7 @@ keys-%.c: utils/key2pub.py $(wildcard $(
18 $(NQ) ' Trusted pubkeys:' $(wildcard $(PUBKEY_DIR)/*.pem)
19 $(Q)./utils/key2pub.py --$* $(wildcard $(PUBKEY_DIR)/*.pem) $@
20
21-$(LIBREG): regdb.h reglib.h reglib.c
22+$(LIBREG): reglib.c
23 $(NQ) ' CC ' $@
24 $(Q)$(CC) $(CFLAGS) $(CPPFLAGS) -o $@ -shared -Wl,-soname,$(LIBREG) $^ $(LDFLAGS) $(LIBREGLDLIBS)
25