summaryrefslogtreecommitdiffstats
path: root/meta-networking/conf/layer.conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/conf/layer.conf')
-rw-r--r--meta-networking/conf/layer.conf20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/conf/layer.conf b/meta-networking/conf/layer.conf
new file mode 100644
index 000000000..d99d738be
--- /dev/null
+++ b/meta-networking/conf/layer.conf
@@ -0,0 +1,20 @@
1# We have a conf and classes directory, add to BBPATH
2BBPATH .= ":${LAYERDIR}"
3
4# We have a packages directory, add to BBFILES
5BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
6 ${LAYERDIR}/recipes-*/*/*.bbappend"
7
8BBFILE_COLLECTIONS += "networking-layer"
9BBFILE_PATTERN_networking-layer := "^${LAYERDIR}/"
10BBFILE_PRIORITY_networking-layer = "5"
11
12# This should only be incremented on significant changes that will
13# cause compatibility issues with other layers
14LAYERVERSION_networking-layer = "1"
15
16LAYERDEPENDS_networking-layer = "core"
17LAYERDEPENDS_networking-layer = "openembedded-layer"
18LAYERDEPENDS_networking-layer = "meta-python"
19
20LICENSE_PATH += "${LAYERDIR}/licenses"