summaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow/0001-Link-in-libexecinfo-if-it-has-backtrace-API.patch62
-rw-r--r--meta-networking/recipes-protocols/openflow/openflow_git.bb3
2 files changed, 63 insertions, 2 deletions
diff --git a/meta-networking/recipes-protocols/openflow/openflow/0001-Link-in-libexecinfo-if-it-has-backtrace-API.patch b/meta-networking/recipes-protocols/openflow/openflow/0001-Link-in-libexecinfo-if-it-has-backtrace-API.patch
new file mode 100644
index 000000000..6382c2a9a
--- /dev/null
+++ b/meta-networking/recipes-protocols/openflow/openflow/0001-Link-in-libexecinfo-if-it-has-backtrace-API.patch
@@ -0,0 +1,62 @@
1From 2272df8407d86519d72504d6468b710e7eb56de8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 May 2024 00:23:43 -0700
4Subject: [PATCH] Link in libexecinfo if it has backtrace() API
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 m4/libopenflow.m4 | 5 +++++
10 tests/automake.mk | 2 +-
11 utilities/automake.mk | 4 ++--
12 3 files changed, 8 insertions(+), 3 deletions(-)
13
14diff --git a/m4/libopenflow.m4 b/m4/libopenflow.m4
15index 58014ed..c9302b8 100644
16--- a/m4/libopenflow.m4
17+++ b/m4/libopenflow.m4
18@@ -96,6 +96,11 @@ AC_DEFUN([OFP_CHECK_FAULT_LIBS],
19 [AC_CHECK_LIB([dl], [dladdr], [FAULT_LIBS=-ldl])
20 AC_SUBST([FAULT_LIBS])])
21
22+dnl Checks for libraries needed by lib/fault.c.
23+AC_DEFUN([OFP_CHECK_FAULT_LIBS],
24+ [AC_CHECK_LIB([execinfo], [backtrace], [FAULT_LIBS=-lexecinfo])
25+ AC_SUBST([FAULT_LIBS])])
26+
27 dnl Checks for libraries needed by lib/socket-util.c.
28 AC_DEFUN([OFP_CHECK_SOCKET_LIBS],
29 [AC_CHECK_LIB([socket], [connect])
30diff --git a/tests/automake.mk b/tests/automake.mk
31index a4e945a..0944275 100644
32--- a/tests/automake.mk
33+++ b/tests/automake.mk
34@@ -27,7 +27,7 @@ EXTRA_DIST += tests/test-stp.sh
35 noinst_PROGRAMS += tests/test-stp
36
37 tests_test_stp_SOURCES = tests/test-stp.c
38-tests_test_stp_LDADD = lib/libopenflow.a
39+tests_test_stp_LDADD = lib/libopenflow.a $(FAULT_LIBS)
40 stp_files = \
41 tests/test-stp-ieee802.1d-1998 \
42 tests/test-stp-ieee802.1d-2004-fig17.4 \
43diff --git a/utilities/automake.mk b/utilities/automake.mk
44index d6f79a8..0608655 100644
45--- a/utilities/automake.mk
46+++ b/utilities/automake.mk
47@@ -36,10 +36,10 @@ utilities_dpctl_SOURCES = utilities/dpctl.c
48 utilities_dpctl_LDADD = lib/libopenflow.a $(FAULT_LIBS) $(SSL_LIBS)
49
50 utilities_vlogconf_SOURCES = utilities/vlogconf.c
51-utilities_vlogconf_LDADD = lib/libopenflow.a
52+utilities_vlogconf_LDADD = lib/libopenflow.a $(FAULT_LIBS)
53
54 utilities_ofp_discover_SOURCES = utilities/ofp-discover.c
55-utilities_ofp_discover_LDADD = lib/libopenflow.a
56+utilities_ofp_discover_LDADD = lib/libopenflow.a $(FAULT_LIBS)
57
58 utilities_ofp_kill_SOURCES = utilities/ofp-kill.c
59 utilities_ofp_kill_LDADD = lib/libopenflow.a
60--
612.45.1
62
diff --git a/meta-networking/recipes-protocols/openflow/openflow_git.bb b/meta-networking/recipes-protocols/openflow/openflow_git.bb
index 41bedcd0c..aad044a04 100644
--- a/meta-networking/recipes-protocols/openflow/openflow_git.bb
+++ b/meta-networking/recipes-protocols/openflow/openflow_git.bb
@@ -21,6 +21,7 @@ SRC_URI = "git://github.com/mininet/openflow;protocol=https;branch=master \
21 file://0001-generate-not-static-get_dh-functions.patch \ 21 file://0001-generate-not-static-get_dh-functions.patch \
22 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \ 22 file://0001-socket-util-Include-sys-stat.h-for-fchmod.patch \
23 file://0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch \ 23 file://0001-Makefile.am-Specify-export-dynamic-directly-to-linke.patch \
24 file://0001-Link-in-libexecinfo-if-it-has-backtrace-API.patch \
24" 25"
25CVE_STATUS[CVE-2015-1611] = "not-applicable-config: Not referred to our implementation of openflow" 26CVE_STATUS[CVE-2015-1611] = "not-applicable-config: Not referred to our implementation of openflow"
26CVE_STATUS[CVE-2015-1612] = "not-applicable-config: Not referred to our implementation of openflow" 27CVE_STATUS[CVE-2015-1612] = "not-applicable-config: Not referred to our implementation of openflow"
@@ -34,9 +35,7 @@ EXTRA_OECONF += " \
34 KARCH=${TARGET_ARCH} \ 35 KARCH=${TARGET_ARCH} \
35 ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \ 36 ${@bb.utils.contains('PACKAGECONFIG', 'openssl', 'SSL_LIBS="-lssl -lcrypto"', '', d)} \
36 " 37 "
37
38DEPENDS:append:libc-musl = " libexecinfo" 38DEPENDS:append:libc-musl = " libexecinfo"
39LDFLAGS:append:libc-musl = " -lexecinfo"
40 39
41S = "${WORKDIR}/git" 40S = "${WORKDIR}/git"
42 41