summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch')
-rw-r--r--meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
new file mode 100644
index 000000000..950c09b8a
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/vlc/vlc/0006-make-opencv-configurable.patch
@@ -0,0 +1,29 @@
1Recent opencv API changes break upstream filter and example.
2Make opencv explicitly configurable.
3
4Upstream-Status: Inappropriate [configuration]
5
6Signed-off-by: Tim Orling <TicoTimo@gmail.com>
7
8Index: vlc-2.1.4/configure.ac
9===================================================================
10--- vlc-2.1.4.orig/configure.ac
11+++ vlc-2.1.4/configure.ac
12@@ -1693,7 +1693,16 @@ PKG_ENABLE_MODULES_VLC([BLURAY], [libblu
13 dnl
14 dnl OpenCV wrapper and example filters
15 dnl
16-PKG_ENABLE_MODULES_VLC([OPENCV], [opencv_example opencv_wrapper], [opencv > 2.0], (OpenCV (computer vision) filter), [auto])
17+AC_ARG_ENABLE(opencv,
18+ [AS_HELP_STRING([--disable-opencv],
19+ [disable OpenCV computer vision filter and example (default auto)])])
20+if test "${enable_opencv}" != "no"
21+then
22+ PKG_ENABLE_MODULES_VLC([OPENCV],
23+ [opencv_example opencv_wrapper],
24+ [opencv > 2.0],
25+ (OpenCV (computer vision) filter), [auto])
26+fi
27
28
29 dnl