summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.73.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.73.bb')
-rw-r--r--meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.73.bb388
1 files changed, 388 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.73.bb b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.73.bb
new file mode 100644
index 000000000..b27886d0c
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/pipewire/pipewire_0.3.73.bb
@@ -0,0 +1,388 @@
1SUMMARY = "Multimedia processing server for Linux"
2DESCRIPTION = "Linux server for handling and routing audio and video streams between applications and multimedia I/O devices"
3HOMEPAGE = "https://pipewire.org/"
4BUGTRACKER = "https://gitlab.freedesktop.org/pipewire/pipewire/issues"
5AUTHOR = "Wim Taymans <wtaymans@redhat.com>"
6SECTION = "multimedia"
7
8LICENSE = "MIT & LGPL-2.1-or-later & GPL-2.0-only"
9LIC_FILES_CHKSUM = " \
10 file://LICENSE;md5=2158739e172e58dc9ab1bdd2d6ec9c72 \
11 file://COPYING;md5=97be96ca4fab23e9657ffa590b931c1a \
12"
13
14DEPENDS = "dbus ncurses"
15
16SRCREV = "44deacbc670ccf6c02d66a48b756a16167d8048f"
17SRC_URI = "git://gitlab.freedesktop.org/pipewire/pipewire.git;branch=master;protocol=https"
18
19S = "${WORKDIR}/git"
20
21inherit meson pkgconfig systemd gettext useradd
22
23USERADD_PACKAGES = "${PN}"
24
25GROUPADD_PARAM:${PN} = "--system pipewire"
26
27USERADD_PARAM:${PN} = "--system --home / --no-create-home \
28 --comment 'PipeWire multimedia daemon' \
29 --gid pipewire --groups audio,video \
30 pipewire"
31
32SYSTEMD_PACKAGES = "${PN}"
33
34# For "EVL", look up https://evlproject.org/ . It involves
35# a specially prepared kernel, and is currently unavailable
36# in Yocto.
37#
38# Vulkan support is currently (as of version 0.3.44) not functional.
39#
40# manpage generation requires xmltoman, which is not available.
41#
42# The session-managers list specifies which session managers Meson
43# shall download (via git clone) and build as subprojects. In OE,
44# this is not how a session manager should be built. Instead, they
45# should be integrated as separate OE recipes. To prevent PipeWire
46# from using this Meson feature, set an empty list.
47# This does not disable support or the need for session managers,
48# it just prevents this subproject feature.
49#
50# AptX and LDAC are not available in OE. Currently, neither
51# are lv2, ROC, and libmysofa.
52#
53# The RTKit module is deprecated in favor of the newer RT module.
54# It still exists for legacy setups that still include it in
55# their PipeWire configuration files.
56EXTRA_OEMESON += " \
57 -Devl=disabled \
58 -Dtests=disabled \
59 -Dudevrulesdir=${nonarch_base_libdir}/udev/rules.d/ \
60 -Dsystemd-system-unit-dir=${systemd_system_unitdir} \
61 -Dsystemd-user-unit-dir=${systemd_user_unitdir} \
62 -Dman=disabled \
63 -Dsession-managers='[]' \
64 -Dlv2=disabled \
65 -Droc=disabled \
66 -Dbluez5-codec-aptx=disabled \
67 -Dbluez5-codec-ldac=disabled \
68 -Dlegacy-rtkit=false \
69 -Dlibmysofa=disabled \
70"
71
72# spa alsa plugin code uses typedef redefinition, which is officially a C11 feature.
73# Pipewire builds with 'c_std=gnu99' by default. Recent versions of gcc don't issue this warning in gnu99
74# mode but it looks like clang still does
75CFLAGS:append = " -Wno-typedef-redefinition"
76
77# According to wireplumber documentation only one session manager should be installed at a time
78# Possible options are media-session, which has fewer dependencies but is very simple,
79# or wireplumber, which is more powerful.
80PIPEWIRE_SESSION_MANAGER ??= "wireplumber"
81
82FFMPEG_AVAILABLE = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'ffmpeg', '', d)}"
83BLUETOOTH_AAC = "${@bb.utils.contains('LICENSE_FLAGS_ACCEPTED', 'commercial', 'bluez-aac', '', d)}"
84
85PACKAGECONFIG:class-target ??= " \
86 ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
87 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez bluez-opus ${BLUETOOTH_AAC}', '', d)} \
88 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd systemd-system-service systemd-user-service', '', d)} \
89 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa vulkan pulseaudio', d)} \
90 ${PIPEWIRE_SESSION_MANAGER} \
91 ${FFMPEG_AVAILABLE} avahi flatpak gstreamer gsettings jack libusb pw-cat raop sndfile v4l2 udev volume webrtc-echo-cancelling libcamera readline \
92"
93
94# "jack" and "pipewire-jack" packageconfigs cannot be both enabled,
95# since "jack" imports libjack, and "pipewire-jack" generates
96# libjack.so* files, thus colliding with the libpack package. This
97# is why these two are marked in their respective packageconfigs
98# as being in conflict.
99PACKAGECONFIG[alsa] = "-Dalsa=enabled,-Dalsa=disabled,alsa-lib udev,,pipewire-alsa pipewire-alsa-card-profile"
100PACKAGECONFIG[avahi] = "-Davahi=enabled,-Davahi=disabled,avahi"
101PACKAGECONFIG[bluez] = "-Dbluez5=enabled,-Dbluez5=disabled,bluez5 sbc"
102PACKAGECONFIG[bluez-aac] = "-Dbluez5-codec-aac=enabled,-Dbluez5-codec-aac=disabled,fdk-aac"
103PACKAGECONFIG[bluez-opus] = "-Dbluez5-codec-opus=enabled,-Dbluez5-codec-opus=disabled,libopus"
104# From the pipewire git log:
105# "Some Linux phones doesn't use oFono but ModemManager to control the modem."
106# This packageconfig enables modemmanager specific code in the BlueZ backend.
107PACKAGECONFIG[bluez-backend-native-mm] = "-Dbluez5-backend-native-mm=enabled,-Dbluez5-backend-native-mm=disabled,modemmanager"
108PACKAGECONFIG[docs] = "-Ddocs=enabled,-Ddocs=disabled,doxygen-native graphviz-native"
109PACKAGECONFIG[ffmpeg] = "-Dffmpeg=enabled,-Dffmpeg=disabled,ffmpeg"
110PACKAGECONFIG[flatpak] = "-Dflatpak=enabled,-Dflatpak=disabled,glib-2.0"
111PACKAGECONFIG[gsettings] = "-Dgsettings=enabled,-Dgsettings=disabled,glib-2.0"
112PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base,,gstreamer1.0-pipewire"
113PACKAGECONFIG[jack] = "-Djack=enabled,-Djack=disabled,jack,,,pipewire-jack"
114PACKAGECONFIG[libcamera] = "-Dlibcamera=enabled,-Dlibcamera=disabled,libcamera libdrm"
115PACKAGECONFIG[libcanberra] = "-Dlibcanberra=enabled,-Dlibcanberra=disabled,libcanberra"
116PACKAGECONFIG[libusb] = "-Dlibusb=enabled,-Dlibusb=disabled,libusb"
117PACKAGECONFIG[media-session] = ",,,pipewire-media-session,,wireplumber"
118PACKAGECONFIG[pulseaudio] = "-Dlibpulse=enabled,-Dlibpulse=disabled,pulseaudio,,pipewire-pulse"
119PACKAGECONFIG[pipewire-alsa] = "-Dpipewire-alsa=enabled,-Dpipewire-alsa=disabled,alsa-lib"
120PACKAGECONFIG[pipewire-jack] = "-Dpipewire-jack=enabled -Dlibjack-path=${libdir}/${PW_MODULE_SUBDIR}/jack,-Dpipewire-jack=disabled,jack,,pipewire-jack,jack"
121PACKAGECONFIG[pw-cat] = "-Dpw-cat=enabled,-Dpw-cat=disabled"
122PACKAGECONFIG[raop] = "-Draop=enabled,-Draop=disabled,openssl"
123# Starting with version 0.3.60, readline usage can be turned off in pw-cli.
124# If it is disabled, getline() is used as a fallback.
125PACKAGECONFIG[readline] = "-Dreadline=enabled,-Dreadline=disabled,readline"
126PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,libsdl2"
127PACKAGECONFIG[sndfile] = "-Dsndfile=enabled,-Dsndfile=disabled,libsndfile1"
128PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd"
129PACKAGECONFIG[systemd-system-service] = "-Dsystemd-system-service=enabled,-Dsystemd-system-service=disabled,systemd"
130# "systemd-user-service" packageconfig will only install service
131# files to rootfs but not enable them as systemd.bbclass
132# currently lacks the feature of enabling user services.
133PACKAGECONFIG[systemd-user-service] = "-Dsystemd-user-service=enabled,-Dsystemd-user-service=disabled,systemd"
134# pw-cat needs sndfile packageconfig to be enabled
135PACKAGECONFIG[udev] = "-Dudev=enabled,-Dudev=disabled,udev"
136PACKAGECONFIG[v4l2] = "-Dv4l2=enabled,-Dv4l2=disabled,udev"
137PACKAGECONFIG[volume] = "-Dvolume=enabled,-Dvolume=disabled"
138PACKAGECONFIG[vulkan] = "-Dvulkan=enabled,-Dvulkan=disabled,vulkan-headers vulkan-loader"
139PACKAGECONFIG[webrtc-echo-cancelling] = "-Decho-cancel-webrtc=enabled,-Decho-cancel-webrtc=disabled,webrtc-audio-processing"
140PACKAGECONFIG[wireplumber] = ",,,wireplumber,,media-session"
141
142PACKAGESPLITFUNCS:prepend = " split_dynamic_packages "
143PACKAGESPLITFUNCS:append = " set_dynamic_metapkg_rdepends "
144
145SPA_SUBDIR = "spa-0.2"
146PW_MODULE_SUBDIR = "pipewire-0.3"
147
148remove_unused_installed_files() {
149 # jack.conf is used by pipewire-jack (not the JACK SPA plugin).
150 # Remove it if pipewire-jack is not built to avoid creating the
151 # pipewire-jack package.
152 if ${@bb.utils.contains('PACKAGECONFIG', 'pipewire-jack', 'false', 'true', d)}; then
153 rm -f "${D}${datadir}/pipewire/jack.conf"
154 fi
155
156 # minimal.conf is an example of how to minimally configure the
157 # daemon and is not meant to be used for production.
158 rm -f "${D}${datadir}/pipewire/minimal.conf"
159}
160
161do_install[postfuncs] += "remove_unused_installed_files"
162
163python split_dynamic_packages () {
164 # Create packages for each SPA plugin. These plugins are located
165 # in individual subdirectories, so a recursive search is needed.
166 spa_libdir = d.expand('${libdir}/${SPA_SUBDIR}')
167 do_split_packages(d, spa_libdir, r'^libspa-(.*)\.so$', d.expand('${PN}-spa-plugins-%s'), 'PipeWire SPA plugin for %s', extra_depends='', recursive=True)
168
169 # Create packages for each PipeWire module.
170 pw_module_libdir = d.expand('${libdir}/${PW_MODULE_SUBDIR}')
171 do_split_packages(d, pw_module_libdir, r'^libpipewire-module-(.*)\.so$', d.expand('${PN}-modules-%s'), 'PipeWire %s module', extra_depends='', recursive=False)
172}
173
174python set_dynamic_metapkg_rdepends () {
175 import os
176 import oe.utils
177
178 if bb.data.inherits_class('nativesdk', d) or bb.data.inherits_class('native', d):
179 return
180
181 # Go through all generated SPA plugin and PipeWire module packages
182 # (excluding the main package and the -meta package itself) and
183 # add them to the -meta package as RDEPENDS.
184
185 base_pn = d.getVar('PN')
186
187 spa_pn = base_pn + '-spa-plugins'
188 spa_metapkg = spa_pn + '-meta'
189
190 pw_module_pn = base_pn + '-modules'
191 pw_module_metapkg = pw_module_pn + '-meta'
192
193 d.setVar('ALLOW_EMPTY:' + spa_metapkg, "1")
194 d.setVar('FILES:' + spa_metapkg, "")
195
196 d.setVar('ALLOW_EMPTY:' + pw_module_metapkg, "1")
197 d.setVar('FILES:' + pw_module_metapkg, "")
198
199 blacklist = [ spa_pn, spa_metapkg, pw_module_pn, pw_module_metapkg ]
200 spa_metapkg_rdepends = []
201 pw_module_metapkg_rdepends = []
202 pkgdest = d.getVar('PKGDEST')
203
204 for pkg in oe.utils.packages_filter_out_system(d):
205 if pkg in blacklist:
206 continue
207
208 is_spa_pkg = pkg.startswith(spa_pn)
209 is_pw_module_pkg = pkg.startswith(pw_module_pn)
210 if not is_spa_pkg and not is_pw_module_pkg:
211 continue
212
213 if pkg in spa_metapkg_rdepends or pkg in pw_module_metapkg_rdepends:
214 continue
215
216 # See if the package is empty by looking at the contents of its
217 # PKGDEST subdirectory. If this subdirectory is empty, then then
218 # package is empty as well. Empty packages do not get added to
219 # the meta package's RDEPENDS.
220 pkgdir = os.path.join(pkgdest, pkg)
221 if os.path.exists(pkgdir):
222 dir_contents = os.listdir(pkgdir) or []
223 else:
224 dir_contents = []
225 is_empty = len(dir_contents) == 0
226 if not is_empty:
227 if is_spa_pkg:
228 spa_metapkg_rdepends.append(pkg)
229 if is_pw_module_pkg:
230 pw_module_metapkg_rdepends.append(pkg)
231
232 d.setVar('RDEPENDS:' + spa_metapkg, ' '.join(spa_metapkg_rdepends))
233 d.setVar('DESCRIPTION:' + spa_metapkg, spa_pn + ' meta package')
234
235 d.setVar('RDEPENDS:' + pw_module_metapkg, ' '.join(pw_module_metapkg_rdepends))
236 d.setVar('DESCRIPTION:' + pw_module_metapkg, pw_module_pn + ' meta package')
237}
238
239PACKAGES =+ "\
240 libpipewire \
241 ${PN}-tools \
242 ${PN}-pulse \
243 ${PN}-alsa \
244 ${PN}-jack \
245 ${PN}-spa-plugins \
246 ${PN}-spa-plugins-meta \
247 ${PN}-spa-tools \
248 ${PN}-modules \
249 ${PN}-modules-meta \
250 ${PN}-alsa-card-profile \
251 ${PN}-v4l2 \
252 ${PN}-aes67 \
253 gstreamer1.0-pipewire \
254"
255
256PACKAGES_DYNAMIC = "^${PN}-spa-plugins.* ^${PN}-modules.*"
257PACKAGES_DYNAMIC:class-native = ""
258
259SYSTEMD_SERVICE:${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'systemd-system-service', 'pipewire.service', '', d)}"
260CONFFILES:${PN} += "${datadir}/pipewire/pipewire.conf"
261FILES:${PN} = " \
262 ${datadir}/pipewire \
263 ${systemd_system_unitdir}/pipewire* \
264 ${systemd_user_unitdir} \
265 ${bindir}/pipewire \
266 ${bindir}/pipewire-avb \
267"
268
269RRECOMMENDS:${PN}:class-target += " \
270 pipewire-modules-meta \
271 pipewire-spa-plugins-meta \
272"
273
274FILES:${PN}-dev += " \
275 ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so \
276"
277
278CONFFILES:libpipewire += "${datadir}/pipewire/client.conf"
279FILES:libpipewire = " \
280 ${datadir}/pipewire/client.conf \
281 ${libdir}/libpipewire-*.so.* \
282"
283# Add the bare minimum modules and plugins required to be able
284# to use libpipewire. Without these, it is essentially unusable.
285RDEPENDS:libpipewire += " \
286 ${PN}-modules-client-node \
287 ${PN}-modules-protocol-native \
288 ${PN}-spa-plugins-support \
289"
290
291FILES:${PN}-tools = " \
292 ${bindir}/pw-cat \
293 ${bindir}/pw-cli \
294 ${bindir}/pw-config \
295 ${bindir}/pw-dot \
296 ${bindir}/pw-dsdplay \
297 ${bindir}/pw-dump \
298 ${bindir}/pw-encplay \
299 ${bindir}/pw-link \
300 ${bindir}/pw-loopback \
301 ${bindir}/pw-metadata \
302 ${bindir}/pw-mididump \
303 ${bindir}/pw-midiplay \
304 ${bindir}/pw-midirecord \
305 ${bindir}/pw-mon \
306 ${bindir}/pw-play \
307 ${bindir}/pw-profiler \
308 ${bindir}/pw-record \
309 ${bindir}/pw-reserve \
310 ${bindir}/pw-top \
311"
312
313# This is a shim daemon that is intended to be used as a
314# drop-in PulseAudio replacement, providing a pulseaudio-compatible
315# socket that can be used by applications that use libpulse.
316CONFFILES:${PN}-pulse += "${datadir}/pipewire/pipewire-pulse.conf"
317FILES:${PN}-pulse = " \
318 ${datadir}/pipewire/pipewire-pulse.conf \
319 ${systemd_system_unitdir}/pipewire-pulse.* \
320 ${systemd_user_unitdir}/pipewire-pulse.* \
321 ${bindir}/pipewire-pulse \
322"
323RDEPENDS:${PN}-pulse += " \
324 ${PN}-modules-protocol-pulse \
325"
326
327# ALSA plugin to redirect audio to pipewire.
328FILES:${PN}-alsa = "\
329 ${libdir}/alsa-lib/* \
330 ${datadir}/alsa/alsa.conf.d/* \
331"
332
333# JACK drop-in libraries to redirect audio to pipewire.
334CONFFILES:${PN}-jack = "${datadir}/pipewire/jack.conf"
335FILES:${PN}-jack = "\
336 ${bindir}/pw-jack \
337 ${datadir}/pipewire/jack.conf \
338 ${libdir}/${PW_MODULE_SUBDIR}/jack/libjack*.so.* \
339"
340
341# Dynamic SPA plugin packages (see set_dynamic_metapkg_rdepends).
342FILES:${PN}-spa-plugins = ""
343RRECOMMENDS:${PN}-spa-plugins += "${PN}-spa-plugins-meta"
344
345FILES:${PN}-spa-plugins-bluez5 += " \
346 ${datadir}/${SPA_SUBDIR}/bluez5/* \
347"
348
349FILES:${PN}-spa-tools = " \
350 ${bindir}/spa-* \
351"
352
353# Dynamic PipeWire module packages (see set_dynamic_metapkg_rdepends).
354FILES:${PN}-modules = ""
355RRECOMMENDS:${PN}-modules += "${PN}-modules-meta"
356
357CONFFILES:${PN}-modules-rt = "${datadir}/pipewire/client-rt.conf"
358FILES:${PN}-modules-rt += " \
359 ${datadir}/pipewire/client-rt.conf \
360 ${sysconfdir}/security/limits.d/* \
361 "
362
363CONFFILES:${PN}-modules-filter-chain = "${datadir}/pipewire/filter-chain/*"
364FILES:${PN}-modules-filter-chain += " \
365 ${datadir}/pipewire/filter-chain/* \
366"
367
368FILES:${PN}-alsa-card-profile = " \
369 ${datadir}/alsa-card-profile/* \
370 ${nonarch_base_libdir}/udev/rules.d/90-pipewire-alsa.rules \
371"
372
373# V4L2 interface emulator for sending/receiving data between PipeWire and V4L2 applications.
374FILES:${PN}-v4l2 += " \
375 ${bindir}/pw-v4l2 \
376 ${libdir}/${PW_MODULE_SUBDIR}/v4l2/libpw-v4l2.so \
377"
378
379# AES67 is a standard for audio over IP, from the Audio Engineering Society (AES).
380FILES:${PN}-aes67 += " \
381 ${bindir}/pipewire-aes67 \
382"
383
384FILES:gstreamer1.0-pipewire = " \
385 ${libdir}/gstreamer-1.0/* \
386"
387
388BBCLASSEXTEND = "native nativesdk"