diff options
Diffstat (limited to 'meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb')
-rw-r--r-- | meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb b/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb new file mode 100644 index 000000000..a6a4f6a8a --- /dev/null +++ b/meta-multimedia/recipes-multimedia/musicbrainz/libmusicbrainz_git.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | SUMMARY = "MusicBrainz client library" | ||
2 | DESCRIPTION = "The MusicBrainz client is a library which can be built into other programs. The library allows you to access the data held on the MusicBrainz server." | ||
3 | HOMEPAGE = "http://musicbrainz.org" | ||
4 | LICENSE = "LGPLv2.1+" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=fbc093901857fcd118f065f900982c24" | ||
6 | DEPENDS = "expat neon neon-native" | ||
7 | |||
8 | PV = "5.0.1+git${SRCPV}" | ||
9 | PR = "r1" | ||
10 | |||
11 | SRCREV = "0749dd0a35b4a54316da064475863a4ac6e28e7e" | ||
12 | SRC_URI = "git://github.com/metabrainz/libmusicbrainz.git \ | ||
13 | file://allow-libdir-override.patch " | ||
14 | |||
15 | S = "${WORKDIR}/git" | ||
16 | |||
17 | LDFLAGS_prepend_libc-uclibc = " -lpthread " | ||
18 | |||
19 | inherit cmake pkgconfig | ||
20 | |||
21 | do_configure_prepend() { | ||
22 | # The native build really doesn't like being rebuilt, so delete | ||
23 | # it if it's already present. Also delete all other files not | ||
24 | # known to Git to fix subsequent invocations of do_configure. | ||
25 | git clean -dfx -e /.pc/ -e /patches/ . | ||
26 | mkdir build-native | ||
27 | cd build-native | ||
28 | cmake -DCMAKE_C_FLAGS=${BUILD_CFLAGS} \ | ||
29 | -DCMAKE_C_COMPILER=${BUILD_CC} \ | ||
30 | -DCMAKE_CXX_FLAGS=${BUILD_CXXFLAGS} \ | ||
31 | -DCMAKE_CXX_COMPILER=${BUILD_CXX} \ | ||
32 | .. | ||
33 | make make-c-interface | ||
34 | cd .. | ||
35 | } | ||
36 | |||
37 | EXTRA_OECMAKE = "-DLIB_INSTALL_DIR:PATH=${libdir} \ | ||
38 | -DIMPORT_EXECUTABLES=build-native/ImportExecutables.cmake" | ||
39 | |||
40 | # out-of-tree building doesn't appear to work for this package. | ||
41 | B = "${S}" | ||