diff options
Diffstat (limited to 'meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb')
-rw-r--r-- | meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb | 78 |
1 files changed, 78 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb b/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb new file mode 100644 index 000000000..419d6e8d2 --- /dev/null +++ b/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb | |||
@@ -0,0 +1,78 @@ | |||
1 | SUMMARY = "Bluetooth Audio ALSA Backend" | ||
2 | DESCRIPTION = "\ | ||
3 | BlueALSA is a replacement for BlueZ >= 5, with which one can achieve the \ | ||
4 | same Bluetooth audio profile support as with PulseAudio, but with fewer \ | ||
5 | dependencies and at a lower level in the software stack. It is designed \ | ||
6 | specifically for use on small, low-powered, dedicated audio or audio/visual \ | ||
7 | systems where the high-level audio management features of PulseAudio or \ | ||
8 | PipeWire are not required. \ | ||
9 | " | ||
10 | HOMEPAGE = "https://github.com/Arkq/bluez-alsa" | ||
11 | BUGTRACKER = "https://github.com/arkq/bluez-alsa/issues" | ||
12 | SECTION = "libs" | ||
13 | |||
14 | LICENSE = "MIT" | ||
15 | LIC_FILES_CHKSUM = "file://LICENSE;md5=143bc4e73f39cc5e89d6e096ac0315ba" | ||
16 | |||
17 | DEPENDS += "alsa-lib bluez5 dbus glib-2.0-native python3-packaging-native sbc" | ||
18 | |||
19 | SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master" | ||
20 | |||
21 | SRCREV = "959573c2cccef5cf074f5b2fa7941abbd699c5f4" | ||
22 | |||
23 | S = "${WORKDIR}/git" | ||
24 | |||
25 | PACKAGECONFIG ??= "aplay cli hcitop ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" | ||
26 | PACKAGECONFIG[a2dpconf] = "--enable-a2dpconf,--disable-a2dpconf" | ||
27 | PACKAGECONFIG[aac] = "--enable-aac,--disable-aac,fdk-aac" | ||
28 | PACKAGECONFIG[aplay] = "--enable-aplay,--disable-aplay" | ||
29 | PACKAGECONFIG[cli] = "--enable-cli,--disable-cli" | ||
30 | PACKAGECONFIG[coverage] = "--with-coverage,--without-coverage,lcov-native" | ||
31 | PACKAGECONFIG[debug] = "--enable-debug,--disable-debug" | ||
32 | PACKAGECONFIG[debug-time] = "--enable-debug-time,--disable-debug-time" | ||
33 | PACKAGECONFIG[faststream] = "--enable-faststream,--disable-faststream" | ||
34 | PACKAGECONFIG[hcitop] = "--enable-hcitop,--disable-hcitop,libbsd ncurses" | ||
35 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" | ||
36 | PACKAGECONFIG[midi] = "--enable-midi,--disable-midi" | ||
37 | PACKAGECONFIG[mp3lame] = "--enable-mp3lame,--disable-mp3lame,lame" | ||
38 | PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123,mpg123" | ||
39 | PACKAGECONFIG[msbc] = "--enable-msbc,--disable-msbc,spandsp" | ||
40 | PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono,ofono" | ||
41 | PACKAGECONFIG[payloadcheck] = "--enable-payloadcheck,--disable-payloadcheck" | ||
42 | PACKAGECONFIG[rfcomm] = "--enable-rfcomm,--disable-rfcomm" | ||
43 | PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir} \ | ||
44 | --with-systemdbluealsaargs='${SYSTEMD_BLUEALSA_ARGS}' --with-systemdbluealsaaplayargs='${SYSTEMD_BLUEALSA_APLAY_ARGS}',--disable-systemd,systemd" | ||
45 | PACKAGECONFIG[test] = "--enable-test,--disable-test,libcheck libsndfile1" | ||
46 | PACKAGECONFIG[upower] = "--enable-upower,--disable-upower,,upower" | ||
47 | |||
48 | inherit autotools pkgconfig python3native systemd | ||
49 | |||
50 | # These proprietary codecs are not available in Yocto | ||
51 | EXTRA_OECONF = "\ | ||
52 | --disable-aptx \ | ||
53 | --disable-lc3plus \ | ||
54 | --disable-ldac \ | ||
55 | --disable-manpages \ | ||
56 | " | ||
57 | |||
58 | PACKAGE_BEFORE_PN = "${PN}-aplay" | ||
59 | |||
60 | FILES:${PN}-aplay += "${bindir}/bluealsa-aplay" | ||
61 | FILES:${PN} += "${libdir}/alsa-lib/* ${datadir}/dbus-1/system.d" | ||
62 | |||
63 | RRECOMMENDS:${PN} = "${PN}-aplay" | ||
64 | |||
65 | SYSTEMD_PACKAGES += "${PN}-aplay" | ||
66 | SYSTEMD_SERVICE:${PN} = "bluealsa.service" | ||
67 | SYSTEMD_SERVICE:${PN}-aplay = "bluealsa-aplay.service" | ||
68 | |||
69 | SYSTEMD_AUTO_ENABLE:${PN}-aplay = "disable" | ||
70 | |||
71 | # Choose bluez-alsa arguments to be used in bluealsa systemd service | ||
72 | # Usually could choose profiles with it: a2dp-source a2dp-sink hfp-hf hfp-ag hsp-hs hsp-ag hfp-ofono | ||
73 | # Enable bluez-alsa arguments by default: | ||
74 | SYSTEMD_BLUEALSA_ARGS ?= "-p a2dp-source -p a2dp-sink" | ||
75 | |||
76 | # Choose bluealsa-aplay arguments to be used in bluealsa-aplay systemd service | ||
77 | # Defaults to be empty: | ||
78 | SYSTEMD_BLUEALSA_APLAY_ARGS ?= "" | ||