summaryrefslogtreecommitdiffstats
path: root/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb')
-rw-r--r--meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb b/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb
new file mode 100644
index 000000000..419d6e8d2
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/bluealsa/bluealsa_4.3.0.bb
@@ -0,0 +1,78 @@
1SUMMARY = "Bluetooth Audio ALSA Backend"
2DESCRIPTION = "\
3 BlueALSA is a replacement for BlueZ >= 5, with which one can achieve the \
4 same Bluetooth audio profile support as with PulseAudio, but with fewer \
5 dependencies and at a lower level in the software stack. It is designed \
6 specifically for use on small, low-powered, dedicated audio or audio/visual \
7 systems where the high-level audio management features of PulseAudio or \
8 PipeWire are not required. \
9"
10HOMEPAGE = "https://github.com/Arkq/bluez-alsa"
11BUGTRACKER = "https://github.com/arkq/bluez-alsa/issues"
12SECTION = "libs"
13
14LICENSE = "MIT"
15LIC_FILES_CHKSUM = "file://LICENSE;md5=143bc4e73f39cc5e89d6e096ac0315ba"
16
17DEPENDS += "alsa-lib bluez5 dbus glib-2.0-native python3-packaging-native sbc"
18
19SRC_URI = "git://github.com/Arkq/bluez-alsa.git;protocol=https;branch=master"
20
21SRCREV = "959573c2cccef5cf074f5b2fa7941abbd699c5f4"
22
23S = "${WORKDIR}/git"
24
25PACKAGECONFIG ??= "aplay cli hcitop ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
26PACKAGECONFIG[a2dpconf] = "--enable-a2dpconf,--disable-a2dpconf"
27PACKAGECONFIG[aac] = "--enable-aac,--disable-aac,fdk-aac"
28PACKAGECONFIG[aplay] = "--enable-aplay,--disable-aplay"
29PACKAGECONFIG[cli] = "--enable-cli,--disable-cli"
30PACKAGECONFIG[coverage] = "--with-coverage,--without-coverage,lcov-native"
31PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
32PACKAGECONFIG[debug-time] = "--enable-debug-time,--disable-debug-time"
33PACKAGECONFIG[faststream] = "--enable-faststream,--disable-faststream"
34PACKAGECONFIG[hcitop] = "--enable-hcitop,--disable-hcitop,libbsd ncurses"
35PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
36PACKAGECONFIG[midi] = "--enable-midi,--disable-midi"
37PACKAGECONFIG[mp3lame] = "--enable-mp3lame,--disable-mp3lame,lame"
38PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123,mpg123"
39PACKAGECONFIG[msbc] = "--enable-msbc,--disable-msbc,spandsp"
40PACKAGECONFIG[ofono] = "--enable-ofono,--disable-ofono,ofono"
41PACKAGECONFIG[payloadcheck] = "--enable-payloadcheck,--disable-payloadcheck"
42PACKAGECONFIG[rfcomm] = "--enable-rfcomm,--disable-rfcomm"
43PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir} \
44 --with-systemdbluealsaargs='${SYSTEMD_BLUEALSA_ARGS}' --with-systemdbluealsaaplayargs='${SYSTEMD_BLUEALSA_APLAY_ARGS}',--disable-systemd,systemd"
45PACKAGECONFIG[test] = "--enable-test,--disable-test,libcheck libsndfile1"
46PACKAGECONFIG[upower] = "--enable-upower,--disable-upower,,upower"
47
48inherit autotools pkgconfig python3native systemd
49
50# These proprietary codecs are not available in Yocto
51EXTRA_OECONF = "\
52 --disable-aptx \
53 --disable-lc3plus \
54 --disable-ldac \
55 --disable-manpages \
56"
57
58PACKAGE_BEFORE_PN = "${PN}-aplay"
59
60FILES:${PN}-aplay += "${bindir}/bluealsa-aplay"
61FILES:${PN} += "${libdir}/alsa-lib/* ${datadir}/dbus-1/system.d"
62
63RRECOMMENDS:${PN} = "${PN}-aplay"
64
65SYSTEMD_PACKAGES += "${PN}-aplay"
66SYSTEMD_SERVICE:${PN} = "bluealsa.service"
67SYSTEMD_SERVICE:${PN}-aplay = "bluealsa-aplay.service"
68
69SYSTEMD_AUTO_ENABLE:${PN}-aplay = "disable"
70
71# Choose bluez-alsa arguments to be used in bluealsa systemd service
72# Usually could choose profiles with it: a2dp-source a2dp-sink hfp-hf hfp-ag hsp-hs hsp-ag hfp-ofono
73# Enable bluez-alsa arguments by default:
74SYSTEMD_BLUEALSA_ARGS ?= "-p a2dp-source -p a2dp-sink"
75
76# Choose bluealsa-aplay arguments to be used in bluealsa-aplay systemd service
77# Defaults to be empty:
78SYSTEMD_BLUEALSA_APLAY_ARGS ?= ""