summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-devtools/grubby/grubby_git.bb')
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby_git.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby_git.bb b/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
new file mode 100644
index 000000000..8430b7e10
--- /dev/null
+++ b/meta-initramfs/recipes-devtools/grubby/grubby_git.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A command line tool for updating and displaying info about boot loaders"
2DESCRIPTION = "grubby is a command line tool for updating and displaying information \
3about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \
4zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \
5new kernels and need to find information about the current boot environment. \
6"
7HOMEPAGE = "https://github.com/rhboot/grubby"
8LICENSE = "GPLv2+"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a"
11
12DEPENDS = "popt util-linux"
13DEPENDS_append_libc-musl = " libexecinfo"
14
15S = "${WORKDIR}/git"
16SRCREV = "a1d2ae93408c3408e672d7eba4550fdf27fb0201"
17SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https; \
18 file://grubby-rename-grub2-editenv-to-grub-editenv.patch \
19 file://run-ptest \
20 file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \
21 file://0002-include-paths.h-for-_PATH_MOUNTED.patch \
22 "
23
24RDEPENDS_${PN} += "dracut"
25
26inherit autotools-brokensep ptest
27
28EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}'"
29
30LIBS_libc-musl = "-lexecinfo"
31LIBS ?= ""
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}
34 cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH}
35 sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh
36}
37
38RDEPENDS_${PN}-ptest = "util-linux-getopt bash"
39
40COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)'