summaryrefslogtreecommitdiffstats
path: root/meta-initramfs/recipes-devtools/grubby/grubby
diff options
context:
space:
mode:
Diffstat (limited to 'meta-initramfs/recipes-devtools/grubby/grubby')
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch14
-rw-r--r--meta-initramfs/recipes-devtools/grubby/grubby/grubby-rename-grub2-editenv-to-grub-editenv.patch59
2 files changed, 39 insertions, 34 deletions
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch b/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch
index 1b1a993a0..dfbe7ba6b 100644
--- a/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch
+++ b/meta-initramfs/recipes-devtools/grubby/grubby/0001-Add-another-variable-LIBS-to-provides-libraries-from.patch
@@ -1,26 +1,24 @@
1From 22afaa21b4b258082be591e54c99e1ba6fbd7748 Mon Sep 17 00:00:00 2001 1From b7b3caa9b5c8abcd3c371d0683001cd681e104b3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 15 Jul 2017 10:19:22 -0700 3Date: Sat, 15 Jul 2017 10:19:22 -0700
4Subject: [PATCH 1/2] Add another variable LIBS to provides libraries from env 4Subject: [PATCH 1/2] Add another variable LIBS to provides libraries from env
5 5
6Signed-off-by: Khem Raj <raj.khem@gmail.com> 6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
7--- 8---
8 Makefile | 2 +- 9 Makefile | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-) 10 1 file changed, 1 insertion(+), 1 deletion(-)
10 11
11diff --git a/Makefile b/Makefile 12diff --git a/Makefile b/Makefile
12index ac14404..92a8e73 100644 13index cc7e823..ae30a07 100644
13--- a/Makefile 14--- a/Makefile
14+++ b/Makefile 15+++ b/Makefile
15@@ -27,7 +27,7 @@ RPM_OPT_FLAGS ?= -O2 -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector 16@@ -31,7 +31,7 @@ ifneq ($(VERBOSE_TEST),)
16 CFLAGS += $(RPM_OPT_FLAGS) -std=gnu99 -Wall -Werror -Wno-error=unused-function -Wno-unused-function -ggdb 17 VERBOSE_TEST="--verbose"
17 LDFLAGS := 18 endif
18 19
19-grubby_LIBS = -lblkid -lpopt 20-grubby_LIBS = -lblkid -lpopt
20+grubby_LIBS = -lblkid -lpopt ${LIBS} 21+grubby_LIBS = -lblkid -lpopt ${LIBS}
21 22
22 all: grubby 23 all: grubby
23 24
24--
252.13.3
26
diff --git a/meta-initramfs/recipes-devtools/grubby/grubby/grubby-rename-grub2-editenv-to-grub-editenv.patch b/meta-initramfs/recipes-devtools/grubby/grubby/grubby-rename-grub2-editenv-to-grub-editenv.patch
index d936249be..e693916e1 100644
--- a/meta-initramfs/recipes-devtools/grubby/grubby/grubby-rename-grub2-editenv-to-grub-editenv.patch
+++ b/meta-initramfs/recipes-devtools/grubby/grubby/grubby-rename-grub2-editenv-to-grub-editenv.patch
@@ -1,4 +1,4 @@
1From 0841706a5b5280e501c8e392c70c466c5fbcf0aa Mon Sep 17 00:00:00 2001 1From 15f0572f2f456c2c1b700bc790d9ce7a5c13cc74 Mon Sep 17 00:00:00 2001
2From: Jackie Huang <jackie.huang@windriver.com> 2From: Jackie Huang <jackie.huang@windriver.com>
3Date: Tue, 4 Aug 2015 23:54:41 -0700 3Date: Tue, 4 Aug 2015 23:54:41 -0700
4Subject: [PATCH] rename grub2-editenv to grub-editenv 4Subject: [PATCH] rename grub2-editenv to grub-editenv
@@ -8,38 +8,48 @@ We don't use the name grub2-editenv for grub2.
8Upstream-Status: Inappropriate 8Upstream-Status: Inappropriate
9 9
10Signed-off-by: Jackie Huang <jackie.huang@windriver.com> 10Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
11
11--- 12---
12 grubby.c | 4 ++-- 13 grubby.c | 4 ++--
13 test.sh | 6 +++--- 14 test.sh | 8 ++++----
14 2 files changed, 5 insertions(+), 5 deletions(-) 15 2 files changed, 6 insertions(+), 6 deletions(-)
15 16
16diff --git a/grubby.c b/grubby.c 17diff --git a/grubby.c b/grubby.c
17index d4ebb86..47a1a15 100644 18index 396041a..3ceae69 100644
18--- a/grubby.c 19--- a/grubby.c
19+++ b/grubby.c 20+++ b/grubby.c
20@@ -290,7 +290,7 @@ static char *grub2GetEnv(struct configFileInfo *info, char *name) 21@@ -301,7 +301,7 @@ static char *grub2GetEnv(struct configFileInfo *info, char *name)
21 char *s = NULL; 22 char *ret = NULL;
22 char *ret = NULL; 23 char *envFile = info->envFile ? info->envFile : "/boot/grub2/grubenv";
23 char *envFile = info->envFile ? info->envFile : "/boot/grub2/grubenv"; 24 int rc =
24- int rc = asprintf(&s, "grub2-editenv %s list | grep '^%s='", envFile, name); 25- asprintf(&s, "grub2-editenv %s list | grep '^%s='", envFile, name);
25+ int rc = asprintf(&s, "grub-editenv %s list | grep '^%s='", envFile, name); 26+ asprintf(&s, "grub-editenv %s list | grep '^%s='", envFile, name);
26 27
27 if (rc < 0) 28 if (rc < 0)
28 return NULL; 29 return NULL;
29@@ -361,7 +361,7 @@ static int grub2SetEnv(struct configFileInfo *info, char *name, char *value) 30@@ -373,7 +373,7 @@ static int grub2SetEnv(struct configFileInfo *info, char *name, char *value)
30 if (!value) 31 if (!value)
31 return -1; 32 return -1;
32 33
33- rc = asprintf(&s, "grub2-editenv %s set '%s=%s'", envFile, name, value); 34- rc = asprintf(&s, "grub2-editenv %s set '%s=%s'", envFile, name, value);
34+ rc = asprintf(&s, "grub-editenv %s set '%s=%s'", envFile, name, value); 35+ rc = asprintf(&s, "grub-editenv %s set '%s=%s'", envFile, name, value);
35 free(value); 36 free(value);
36 if (rc <0) 37 if (rc < 0)
37 return -1; 38 return -1;
38diff --git a/test.sh b/test.sh 39diff --git a/test.sh b/test.sh
39index 6379698..f738388 100755 40index 33d24cf..009479c 100755
40--- a/test.sh 41--- a/test.sh
41+++ b/test.sh 42+++ b/test.sh
42@@ -574,7 +574,7 @@ if [ "$testgrub2" == "y" ]; then 43@@ -573,7 +573,7 @@ if [ "$testgrub2" == "y" ]; then
44 --remove-kernel=/boot/vmlinuz-2.6.38.2-9.fc15.x86_64 \
45 --boot-filesystem=/boot/
46 commandTest "saved_default output" \
47- "grub2-editenv test/grub2-support_files/env_temp list" \
48+ "grub-editenv test/grub2-support_files/env_temp list" \
49 "saved_entry=Linux, with Fedora 2.6.38.8-32.fc15.x86_64"
50
51 # copy a stanza and add arguments as well, while using --set-index=
52@@ -627,7 +627,7 @@ if [ "$testgrub2" == "y" ]; then
43 --title='title' --initrd=/boot/new-initrd --boot-filesystem=/boot/ \ 53 --title='title' --initrd=/boot/new-initrd --boot-filesystem=/boot/ \
44 --copy-default 54 --copy-default
45 commandTest "saved_default output" \ 55 commandTest "saved_default output" \
@@ -48,7 +58,7 @@ index 6379698..f738388 100755
48 "saved_entry=Linux, with Fedora 2.6.38.8-32.fc15.x86_64" 58 "saved_entry=Linux, with Fedora 2.6.38.8-32.fc15.x86_64"
49 59
50 testing="GRUB2 add kernel with default=saved_entry and a terrible title" 60 testing="GRUB2 add kernel with default=saved_entry and a terrible title"
51@@ -587,13 +587,13 @@ if [ "$testgrub2" == "y" ]; then 61@@ -640,13 +640,13 @@ if [ "$testgrub2" == "y" ]; then
52 testing="GRUB2 set default with default=saved_entry and a terrible name" 62 testing="GRUB2 set default with default=saved_entry and a terrible name"
53 grub2Test grub2.9 add/g2-1.9 --env grubenv.1 --set-default-index=0 63 grub2Test grub2.9 add/g2-1.9 --env grubenv.1 --set-default-index=0
54 commandTest "saved_default output" \ 64 commandTest "saved_default output" \
@@ -64,6 +74,3 @@ index 6379698..f738388 100755
64 "saved_entry=title" 74 "saved_entry=title"
65 75
66 testing="GRUB2 --default-index with default=saved_entry" 76 testing="GRUB2 --default-index with default=saved_entry"
67--
682.3.5
69