diff options
Diffstat (limited to 'meta-gnome')
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch | 104 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-goabackend-Fix-build-with-libxml2-2.12.patch | 28 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.50.0.bb (renamed from meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb) | 18 |
3 files changed, 7 insertions, 143 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch deleted file mode 100644 index 9bb1d6bb5..000000000 --- a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-Replace-filename-with-basename.patch +++ /dev/null | |||
@@ -1,104 +0,0 @@ | |||
1 | From c4a2951f8a75c4151f009e42b26639e4f456d5a2 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 27 May 2023 14:41:28 -0700 | ||
4 | Subject: [PATCH] Replace filename with basename | ||
5 | |||
6 | This avoids emitting absolute paths into generated sourcecode, it | ||
7 | improves reproducibility. See [1] | ||
8 | |||
9 | [1] https://developer-old.gnome.org/gobject/stable/glib-mkenums.html | ||
10 | |||
11 | Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/merge_requests/125] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | src/goa/goaenumtypes.c.template | 2 +- | ||
15 | src/goa/goaenumtypes.h.template | 2 +- | ||
16 | src/goabackend/goabackendenumtypes.c.template | 2 +- | ||
17 | src/goabackend/goabackendenumtypes.h.template | 2 +- | ||
18 | src/goaidentity/goaidentityenumtypes.c.in | 4 ++-- | ||
19 | src/goaidentity/goaidentityenumtypes.h.in | 2 +- | ||
20 | 6 files changed, 7 insertions(+), 7 deletions(-) | ||
21 | |||
22 | diff --git a/src/goa/goaenumtypes.c.template b/src/goa/goaenumtypes.c.template | ||
23 | index 3150fa71..c2bc4b0a 100644 | ||
24 | --- a/src/goa/goaenumtypes.c.template | ||
25 | +++ b/src/goa/goaenumtypes.c.template | ||
26 | @@ -5,7 +5,7 @@ | ||
27 | /*** END file-header ***/ | ||
28 | |||
29 | /*** BEGIN file-production ***/ | ||
30 | -/* enumerations from "@filename@" */ | ||
31 | +/* enumerations from "@basename@" */ | ||
32 | /*** END file-production ***/ | ||
33 | |||
34 | /*** BEGIN value-header ***/ | ||
35 | diff --git a/src/goa/goaenumtypes.h.template b/src/goa/goaenumtypes.h.template | ||
36 | index 040428c3..14548cb4 100644 | ||
37 | --- a/src/goa/goaenumtypes.h.template | ||
38 | +++ b/src/goa/goaenumtypes.h.template | ||
39 | @@ -9,7 +9,7 @@ G_BEGIN_DECLS | ||
40 | |||
41 | /*** BEGIN file-production ***/ | ||
42 | |||
43 | -/* enumerations from "@filename@" */ | ||
44 | +/* enumerations from "@basename@" */ | ||
45 | /*** END file-production ***/ | ||
46 | |||
47 | /*** BEGIN value-header ***/ | ||
48 | diff --git a/src/goabackend/goabackendenumtypes.c.template b/src/goabackend/goabackendenumtypes.c.template | ||
49 | index 6d2651da..05156bdd 100644 | ||
50 | --- a/src/goabackend/goabackendenumtypes.c.template | ||
51 | +++ b/src/goabackend/goabackendenumtypes.c.template | ||
52 | @@ -5,7 +5,7 @@ | ||
53 | /*** END file-header ***/ | ||
54 | |||
55 | /*** BEGIN file-production ***/ | ||
56 | -/* enumerations from "@filename@" */ | ||
57 | +/* enumerations from "@basename@" */ | ||
58 | /*** END file-production ***/ | ||
59 | |||
60 | /*** BEGIN value-header ***/ | ||
61 | diff --git a/src/goabackend/goabackendenumtypes.h.template b/src/goabackend/goabackendenumtypes.h.template | ||
62 | index 7321076e..51ce84bd 100644 | ||
63 | --- a/src/goabackend/goabackendenumtypes.h.template | ||
64 | +++ b/src/goabackend/goabackendenumtypes.h.template | ||
65 | @@ -9,7 +9,7 @@ G_BEGIN_DECLS | ||
66 | |||
67 | /*** BEGIN file-production ***/ | ||
68 | |||
69 | -/* enumerations from "@filename@" */ | ||
70 | +/* enumerations from "@basename@" */ | ||
71 | /*** END file-production ***/ | ||
72 | |||
73 | /*** BEGIN value-header ***/ | ||
74 | diff --git a/src/goaidentity/goaidentityenumtypes.c.in b/src/goaidentity/goaidentityenumtypes.c.in | ||
75 | index c0286907..8aad7ae4 100644 | ||
76 | --- a/src/goaidentity/goaidentityenumtypes.c.in | ||
77 | +++ b/src/goaidentity/goaidentityenumtypes.c.in | ||
78 | @@ -5,8 +5,8 @@ | ||
79 | /*** END file-header ***/ | ||
80 | |||
81 | /*** BEGIN file-production ***/ | ||
82 | -#include "@filename@" | ||
83 | -/* enumerations from "@filename@" */ | ||
84 | +#include "@basename@" | ||
85 | +/* enumerations from "@basename@" */ | ||
86 | /*** END file-production ***/ | ||
87 | |||
88 | /*** BEGIN value-header ***/ | ||
89 | diff --git a/src/goaidentity/goaidentityenumtypes.h.in b/src/goaidentity/goaidentityenumtypes.h.in | ||
90 | index 35d4d5c5..8719282a 100644 | ||
91 | --- a/src/goaidentity/goaidentityenumtypes.h.in | ||
92 | +++ b/src/goaidentity/goaidentityenumtypes.h.in | ||
93 | @@ -9,7 +9,7 @@ G_BEGIN_DECLS | ||
94 | |||
95 | /*** BEGIN file-production ***/ | ||
96 | |||
97 | -/* enumerations from "@filename@" */ | ||
98 | +/* enumerations from "@basename@" */ | ||
99 | /*** END file-production ***/ | ||
100 | |||
101 | /*** BEGIN value-header ***/ | ||
102 | -- | ||
103 | 2.40.1 | ||
104 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-goabackend-Fix-build-with-libxml2-2.12.patch b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-goabackend-Fix-build-with-libxml2-2.12.patch deleted file mode 100644 index 3d13779c2..000000000 --- a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts/0001-goabackend-Fix-build-with-libxml2-2.12.patch +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | From a2867ebcf184695eed00aab4e7b47c1d4a53b2b2 Mon Sep 17 00:00:00 2001 | ||
2 | From: =?UTF-8?q?J=C3=BCrg=20Billeter?= <j@bitron.ch> | ||
3 | Date: Fri, 24 Nov 2023 16:19:47 +0100 | ||
4 | Subject: [PATCH] goabackend: Fix build with libxml2 2.12 | ||
5 | |||
6 | libxml/xmlIO.h no longer includes libxml/parser.h. | ||
7 | |||
8 | Upstream-Status: Backport [https://github.com/GNOME/gnome-online-accounts/commit/b9638e2418408be4906752297e700506766dcf20] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/goabackend/goaewsclient.c | 1 + | ||
12 | 1 file changed, 1 insertion(+) | ||
13 | |||
14 | diff --git a/src/goabackend/goaewsclient.c b/src/goabackend/goaewsclient.c | ||
15 | index 4cb2358..01a52d1 100644 | ||
16 | --- a/src/goabackend/goaewsclient.c | ||
17 | +++ b/src/goabackend/goaewsclient.c | ||
18 | @@ -27,6 +27,7 @@ | ||
19 | #include <glib/gi18n-lib.h> | ||
20 | |||
21 | #include <libsoup/soup.h> | ||
22 | +#include <libxml/parser.h> | ||
23 | #include <libxml/xmlIO.h> | ||
24 | |||
25 | #include "goaewsclient.h" | ||
26 | -- | ||
27 | 2.44.0 | ||
28 | |||
diff --git a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.50.0.bb index fd61d797d..0af4a5d1e 100644 --- a/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.48.0.bb +++ b/meta-gnome/recipes-gnome/gnome-online-accounts/gnome-online-accounts_3.50.0.bb | |||
@@ -2,25 +2,21 @@ SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME" | |||
2 | LICENSE = "LGPL-2.0-or-later" | 2 | LICENSE = "LGPL-2.0-or-later" |
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36" | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36" |
4 | 4 | ||
5 | GTKIC_VERSION = "4" | ||
6 | inherit gnomebase gsettings gobject-introspection gtk-icon-cache mime-xdg vala features_check | ||
5 | 7 | ||
6 | inherit gnomebase gsettings gobject-introspection gtk-icon-cache vala features_check | 8 | DEPENDS += "gdk-pixbuf dbus glib-2.0 gcr" |
7 | 9 | ||
8 | DEPENDS = "gdk-pixbuf dbus glib-2.0" | 10 | SRC_URI[archive.sha256sum] = "b0f64f0dcfbb8885a3a759e1c9de7fb204adb3ce6bd32c30bcf52d5533c06d4e" |
9 | 11 | ||
10 | SRC_URI += "file://0001-Replace-filename-with-basename.patch \ | 12 | PACKAGECONFIG ?= "goabackend kerberos owncloud google windows_live" |
11 | file://0001-goabackend-Fix-build-with-libxml2-2.12.patch" | ||
12 | SRC_URI[archive.sha256sum] = "418bb9fcffdbd72a98205ad365137617fc1e3551a54de74f6a98d45d266175bf" | ||
13 | 13 | ||
14 | PACKAGECONFIG ?= "goabackend kerberos owncloud lastfm google windows_live" | 14 | PACKAGECONFIG[goabackend] = "-Dgoabackend=true,-Dgoabackend=false,gtk4 libadwaita json-glib libxml2 libsoup rest libsecret webkitgtk" |
15 | 15 | PACKAGECONFIG[kerberos] = "-Dkerberos=true, -Dkerberos=false,krb5" | |
16 | # goabackend requires webkitgtk to be built with gtk+3 and gcr3 | ||
17 | PACKAGECONFIG[goabackend] = "-Dgoabackend=true,-Dgoabackend=false,gtk+3 gtk+3-native json-glib libxml2 libsoup rest libsecret webkitgtk3" | ||
18 | PACKAGECONFIG[kerberos] = "-Dkerberos=true, -Dkerberos=false,krb5 gcr3" | ||
19 | PACKAGECONFIG[exchange] = "-Dexchange=true, -Dexchange=false" | 16 | PACKAGECONFIG[exchange] = "-Dexchange=true, -Dexchange=false" |
20 | PACKAGECONFIG[google] = "-Dgoogle=true, -Dgoogle=false" | 17 | PACKAGECONFIG[google] = "-Dgoogle=true, -Dgoogle=false" |
21 | PACKAGECONFIG[owncloud] = "-Downcloud=true, -Downcloud=false" | 18 | PACKAGECONFIG[owncloud] = "-Downcloud=true, -Downcloud=false" |
22 | PACKAGECONFIG[windows_live] = "-Dwindows_live=true, -Dwindows_live=false" | 19 | PACKAGECONFIG[windows_live] = "-Dwindows_live=true, -Dwindows_live=false" |
23 | PACKAGECONFIG[lastfm] = "-Dlastfm=true, -Dlastfm=false" | ||
24 | 20 | ||
25 | FILES:${PN} += " \ | 21 | FILES:${PN} += " \ |
26 | ${datadir}/dbus-1 \ | 22 | ${datadir}/dbus-1 \ |