diff options
Diffstat (limited to 'meta-gnome/recipes-support')
-rw-r--r-- | meta-gnome/recipes-support/libical/files/pthread-fix.patch | 52 | ||||
-rw-r--r-- | meta-gnome/recipes-support/libical/libical_0.48.bb | 17 |
2 files changed, 69 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/libical/files/pthread-fix.patch b/meta-gnome/recipes-support/libical/files/pthread-fix.patch new file mode 100644 index 000000000..aa7767f22 --- /dev/null +++ b/meta-gnome/recipes-support/libical/files/pthread-fix.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | New added pthread feathre leads some deadlock with some unlock code missing. | ||
2 | This patch fix it. | ||
3 | |||
4 | Signed-off-by: Zhai Edwin <edwin.zhai@intel.com> | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Index: libical-0.47/src/libical/icaltimezone.c | ||
9 | =================================================================== | ||
10 | --- libical-0.47.orig/src/libical/icaltimezone.c 2011-12-16 13:42:25.000000000 +0800 | ||
11 | +++ libical-0.47/src/libical/icaltimezone.c 2011-12-16 14:16:25.000000000 +0800 | ||
12 | @@ -1773,7 +1773,7 @@ | ||
13 | filename = (char*) malloc (filename_len); | ||
14 | if (!filename) { | ||
15 | icalerror_set_errno(ICAL_NEWFAILED_ERROR); | ||
16 | - return; | ||
17 | + goto out; | ||
18 | } | ||
19 | |||
20 | snprintf (filename, filename_len, "%s/%s.ics", get_zone_directory(), | ||
21 | @@ -1783,7 +1783,7 @@ | ||
22 | free (filename); | ||
23 | if (!fp) { | ||
24 | icalerror_set_errno(ICAL_FILE_ERROR); | ||
25 | - return; | ||
26 | + goto out; | ||
27 | } | ||
28 | |||
29 | |||
30 | @@ -1807,7 +1807,7 @@ | ||
31 | |||
32 | if (!subcomp) { | ||
33 | icalerror_set_errno(ICAL_PARSE_ERROR); | ||
34 | - return; | ||
35 | + goto out; | ||
36 | } | ||
37 | |||
38 | icaltimezone_get_vtimezone_properties (zone, subcomp); | ||
39 | @@ -1817,10 +1817,12 @@ | ||
40 | icalcomponent_free(comp); | ||
41 | } | ||
42 | #endif | ||
43 | -#ifdef HAVE_PTHREAD | ||
44 | + | ||
45 | out: | ||
46 | +#ifdef HAVE_PTHREAD | ||
47 | pthread_mutex_unlock(&builtin_mutex); | ||
48 | #endif | ||
49 | + return; | ||
50 | } | ||
51 | |||
52 | |||
diff --git a/meta-gnome/recipes-support/libical/libical_0.48.bb b/meta-gnome/recipes-support/libical/libical_0.48.bb new file mode 100644 index 000000000..80f629c44 --- /dev/null +++ b/meta-gnome/recipes-support/libical/libical_0.48.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | DESCRIPTION = "iCal and scheduling (RFC 2445, 2446, 2447) library" | ||
2 | HOMEPAGE = "http://sourceforge.net/projects/freeassociation/" | ||
3 | BUGTRACKER = "http://sourceforge.net/tracker/?group_id=16077&atid=116077" | ||
4 | LICENSE = "LGPLv2.1 | MPL-1" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d4fc58309d8ed46587ac63bb449d82f8 \ | ||
6 | file://LICENSE;md5=d1a0891cd3e582b3e2ec8fe63badbbb6" | ||
7 | SECTION = "libs" | ||
8 | |||
9 | PR = "r0" | ||
10 | |||
11 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/freeassociation/${BPN}/${P}/${BPN}-${PV}.tar.gz\ | ||
12 | file://pthread-fix.patch" | ||
13 | |||
14 | SRC_URI[md5sum] = "e549f434d5fbf9cd156c60ed4943618f" | ||
15 | SRC_URI[sha256sum] = "2ae78b0757f0dd13431acf42a9a8d038339fd4767fd5134e650bf60ee0b4dff0" | ||
16 | |||
17 | inherit autotools | ||