summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support/onboard/onboard_1.4.1.bb')
-rw-r--r--meta-gnome/recipes-support/onboard/onboard_1.4.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb b/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb
new file mode 100644
index 000000000..3a4f18971
--- /dev/null
+++ b/meta-gnome/recipes-support/onboard/onboard_1.4.1.bb
@@ -0,0 +1,25 @@
1SUMMARY = "An onscreen keyboard"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING.GPL3;md5=8521fa4dd51909b407c5150498d34f4e"
4
5DEPENDS += "gtk+3 hunspell libcanberra libxkbfile dconf python3-distutils-extra-native intltool-native"
6
7SRC_URI = "https://launchpad.net/onboard/1.4/${PV}/+download/${BPN}-${PV}.tar.gz"
8SRC_URI[md5sum] = "1a2fbe82e934f5b37841d17ff51e80e8"
9SRC_URI[sha256sum] = "01cae1ac5b1ef1ab985bd2d2d79ded6fc99ee04b1535cc1bb191e43a231a3865"
10
11inherit setuptools3 pkgconfig gtk-icon-cache gsettings
12
13FILES_${PN} += " \
14 ${datadir}/dbus-1 \
15 ${datadir}/icons \
16 ${datadir}/gnome-shell \
17 ${datadir}/help \
18"
19
20RDEPENDS_${PN} += " \
21 ncurses \
22 python3-dbus \
23 python3-pycairo \
24 python3-pygobject \
25"