summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/libuser/libuser_0.62.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support/libuser/libuser_0.62.bb')
-rw-r--r--meta-gnome/recipes-support/libuser/libuser_0.62.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/libuser/libuser_0.62.bb b/meta-gnome/recipes-support/libuser/libuser_0.62.bb
new file mode 100644
index 000000000..7ec54eb16
--- /dev/null
+++ b/meta-gnome/recipes-support/libuser/libuser_0.62.bb
@@ -0,0 +1,35 @@
1SUMMARY = "user and group account administration library"
2DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \
3and group accounts"
4HOMEPAGE = "https://pagure.io/libuser"
5BUGTRACKER = "https://pagure.io/libuser/issues"
6
7LICENSE = "LGPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
9 file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \
10 file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1"
11
12SECTION = "base"
13
14SRC_URI = "https://releases.pagure.org/libuser/libuser-${PV}.tar.xz \
15 file://0001-Check-for-issetugid.patch \
16 file://0002-remove-unused-execinfo.h.patch \
17 file://0001-modules-files.c-parse_field-fix-string-formating-in-.patch \
18 "
19
20SRC_URI[md5sum] = "63e5e5c551e99dc5302b40b80bd6d4f2"
21SRC_URI[sha256sum] = "a58ff4fabb01a25043b142185a33eeea961109dd60d4b40b6a9df4fa3cace20b"
22
23DEPENDS = "popt libpam glib-2.0 python3"
24
25inherit distro_features_check
26REQUIRED_DISTRO_FEATURES = "pam"
27
28inherit autotools gettext python3native python3-dir pkgconfig gtk-doc
29
30EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}"
31
32PACKAGES += "${PN}-python "
33
34FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
35