summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/goffice
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support/goffice')
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/c99math.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/nodolt.patch12
-rw-r--r--meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch19
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.10.1.bb47
4 files changed, 90 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/goffice/goffice/c99math.patch b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
new file mode 100644
index 000000000..24e6c31a7
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/c99math.patch
@@ -0,0 +1,12 @@
1Index: goffice-0.7.14/configure.in
2===================================================================
3--- goffice-0.7.14.orig/configure.in 2009-11-14 19:14:37.106109501 +0100
4+++ goffice-0.7.14/configure.in 2009-11-14 19:19:40.907333188 +0100
5@@ -66,6 +66,7 @@
6
7 AC_ISC_POSIX
8 AC_PROG_CC
9+AC_PROG_CC_C99
10 AC_PROG_YACC
11 AM_PROG_LEX
12 AC_PROG_LN_S
diff --git a/meta-gnome/recipes-support/goffice/goffice/nodolt.patch b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
new file mode 100644
index 000000000..ea1777a99
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/nodolt.patch
@@ -0,0 +1,12 @@
1Index: goffice-0.7.14/configure.in
2===================================================================
3--- goffice-0.7.14.orig/configure.in
4+++ goffice-0.7.14/configure.in
5@@ -71,7 +71,6 @@ AC_PROG_YACC
6 AM_PROG_LEX
7 AC_PROG_LN_S
8 AM_PROG_LIBTOOL
9-DOLT
10 AC_STDC_HEADERS
11 AC_SYS_LARGEFILE
12
diff --git a/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch b/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch
new file mode 100644
index 000000000..ae9370cfc
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice/pcre-8.30.patch
@@ -0,0 +1,19 @@
1Taken from http://trac.macports.org/ticket/34812
2
3Fixes abiword build failing with:
4/usr/lib/libgoffice-0.8.so: undefined reference to `pcre_info'
5
6Upstream-Status: pending
7
8http://www.linuxfromscratch.org/blfs/view/cvs/x/goffice.html
9--- a/goffice/utils/regutf8.c.orig 2009-09-05 18:52:09.000000000 -0500
10+++ b/goffice/utils/regutf8.c 2012-06-09 18:04:29.000000000 -0500
11@@ -155,7 +155,7 @@
12 default: return GO_REG_BADPAT;
13 }
14 } else {
15- gor->re_nsub = pcre_info (r, NULL, NULL);
16+ gor->re_nsub = pcre_fullinfo (r, NULL, 0, NULL);
17 gor->nosub = (cflags & GO_REG_NOSUB) != 0;
18 return 0;
19 }
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
new file mode 100644
index 000000000..24c4d0ff6
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
@@ -0,0 +1,47 @@
1DESCRIPTION="Gnome Office Library"
2
3LICENSE="GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6dc33ff21e1ba1ac1a2a1069d361e29e"
5
6DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+3 pango cairo libgsf libpcre libxml2 libart-lgpl librsvg"
7
8inherit gnomebase pkgconfig perlnative
9
10GNOME_COMPRESS_TYPE = "xz"
11
12SRC_URI[archive.md5sum] = "90fd17c6fe205b779571e00d9b0b4727"
13SRC_URI[archive.sha256sum] = "5c38f4e81e874cc8e89481b080f77c47c72bfd6fe2526f4fc2ef87c17f96cad0"
14
15FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
16
17RRECOMMENDS_${PN} = " \
18 goffice-plugin-plot-barcol \
19 goffice-plugin-plot-distrib \
20 goffice-plugin-plot-pie \
21 goffice-plugin-plot-radar \
22 goffice-plugin-plot-surface \
23 goffice-plugin-plot-xy \
24 goffice-plugin-reg-linear \
25 goffice-plugin-reg-logfit \
26 goffice-plugin-smoothing \
27"
28
29FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
30 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
31 ${base_bindir}/* ${base_sbindir}/* \
32 ${base_libdir}/*${SOLIBS} \
33 ${datadir}/${PN} \
34 ${datadir}/pixmaps ${datadir}/applications \
35 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
36 ${libdir}/bonobo/servers"
37
38FILES_${PN}-locale = "${libdir}/locale"
39
40PACKAGES_DYNAMIC += "^goffice-plugin-.*"
41
42python populate_packages_prepend () {
43 goffice_libdir = d.expand('${libdir}/goffice/${PV}/plugins/')
44
45 do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
46}
47