summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-support/goffice/goffice_0.10.1.bb')
-rw-r--r--meta-gnome/recipes-support/goffice/goffice_0.10.1.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
new file mode 100644
index 000000000..1e9ec4cfd
--- /dev/null
+++ b/meta-gnome/recipes-support/goffice/goffice_0.10.1.bb
@@ -0,0 +1,47 @@
1DESCRIPTION="Gnome Office Library"
2
3LICENSE="GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=6dc33ff21e1ba1ac1a2a1069d361e29e"
5
6DEPENDS = "libxml-parser-perl-native glib-2.0 gtk+3 pango cairo libgsf libpcre libxml2 libart-lgpl librsvg intltool"
7
8inherit gnomebase pkgconfig perlnative
9
10GNOME_COMPRESS_TYPE = "xz"
11
12SRC_URI[archive.md5sum] = "90fd17c6fe205b779571e00d9b0b4727"
13SRC_URI[archive.sha256sum] = "5c38f4e81e874cc8e89481b080f77c47c72bfd6fe2526f4fc2ef87c17f96cad0"
14
15FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
16
17RRECOMMENDS_${PN} = " \
18 goffice-plugin-plot-barcol \
19 goffice-plugin-plot-distrib \
20 goffice-plugin-plot-pie \
21 goffice-plugin-plot-radar \
22 goffice-plugin-plot-surface \
23 goffice-plugin-plot-xy \
24 goffice-plugin-reg-linear \
25 goffice-plugin-reg-logfit \
26 goffice-plugin-smoothing \
27"
28
29FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
30 ${sysconfdir} ${sharedstatedir} ${localstatedir} \
31 ${base_bindir}/* ${base_sbindir}/* \
32 ${base_libdir}/*${SOLIBS} \
33 ${datadir}/${PN} \
34 ${datadir}/pixmaps ${datadir}/applications \
35 ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
36 ${libdir}/bonobo/servers"
37
38FILES_${PN}-locale = "${libdir}/locale"
39
40PACKAGES_DYNAMIC += "^goffice-plugin-.*"
41
42python populate_packages_prepend () {
43 goffice_libdir = d.expand('${libdir}/goffice/${PV}/plugins/')
44
45 do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
46}
47