summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/yelp/yelp_3.36.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/yelp/yelp_3.36.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/yelp/yelp_3.36.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/yelp/yelp_3.36.0.bb b/meta-gnome/recipes-gnome/yelp/yelp_3.36.0.bb
new file mode 100644
index 000000000..b9263f50c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/yelp/yelp_3.36.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Help browser for the GNOME desktop"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
5"
6
7inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check mime-xdg
8
9# for webkitgtk
10REQUIRED_DISTRO_FEATURES = "x11"
11
12SRC_URI[archive.md5sum] = "32f879293f79b4042edc46aa13d82c71"
13SRC_URI[archive.sha256sum] = "fd4b3e23d31ad2bebe42ac8f80242b2d9bef51418bf62b59acdf2440bd94ed24"
14
15DEPENDS += " \
16 libxml2-native \
17 glib-2.0-native \
18 gtk+3 \
19 appstream-glib \
20 libxslt \
21 sqlite3 \
22 webkitgtk \
23 yelp-xsl \
24"
25
26do_configure_prepend() {
27 export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
28}
29
30FILES_${PN} += " \
31 ${datadir}/metainfo \
32 ${datadir}/yelp-xsl \
33"
34
35RDEPENDS_${PN} += "yelp-xsl"