summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb')
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
new file mode 100644
index 000000000..88f164fc5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.19.bb
@@ -0,0 +1,41 @@
1SUMMARY = "CORBA ORB"
2SECTION = "x11/gnome/libs"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
5SRC_NAME = "ORBit2"
6SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
7SRC_URI = " \
8 ${GNOME_MIRROR}/${SRC_NAME}/${SHRT_VER}/${SRC_NAME}-${PV}.tar.bz2 \
9 file://configure-lossage.patch \
10 file://pkgconfig-fix.patch \
11 file://0001-linc2-src-Makefile.am-fix-build-with-glib-2.36.patch \
12 file://0002-Use-AM_CPPFLAGS-instead-of-INCLUDES-and-fix-problem-.patch \
13"
14SRC_URI[md5sum] = "7082d317a9573ab338302243082d10d1"
15SRC_URI[sha256sum] = "55c900a905482992730f575f3eef34d50bda717c197c97c08fa5a6eafd857550"
16
17BBCLASSEXTEND = "native"
18
19IDL_COMPILER_DEPENDS = "orbit2-native"
20IDL_COMPILER_DEPENDS_virtclass-native = " "
21DEPENDS = "libidl popt ${IDL_COMPILER_DEPENDS}"
22
23# IDL_COMPILER_DEPENDS_virtclass-native for some reason didn't work and orbit2-native
24# was still in orbit2-native DEPENDS causing circular dependency
25DEPENDS_virtclass-native = "libidl-native popt-native"
26PARALLEL_MAKE = ""
27
28
29FILES_${PN} += "${libdir}/orbit-2.0/*.so"
30FILES_${PN}-dev += "${libdir}/orbit-2.0/*.la"
31FILES_${PN}-staticdev += "${libdir}/orbit-2.0/*.a"
32FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
33
34S = "${WORKDIR}/${SRC_NAME}-${PV}"
35
36LEAD_SONAME = "libORBit-2.so"
37
38inherit autotools pkgconfig gtk-doc
39
40EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
41EXTRA_OEMAKE_virtclass-native = " "