summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch')
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch b/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch
new file mode 100644
index 000000000..5fc1de561
--- /dev/null
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2/configure-lossage.patch
@@ -0,0 +1,37 @@
1--- ORBit2-2.14.17/configure.in-orig 2009-01-10 09:36:18.000000000 -0800
2+++ ORBit2-2.14.17/configure.in 2009-06-17 15:10:59.000000000 -0700
3@@ -217,20 +217,20 @@ dnl
4 dnl So many people with broken linking setups asked about this
5 dnl it turned out to be necessary to check for this.
6 dnl
7-dofus_save_libs="$LIBS"
8-LIBS="$ORBIT_LIBS $LIBS"
9-AC_TRY_RUN([ #include <stdio.h>
10- main ()
11- {
12- return 0;
13- } ],,
14- AC_MSG_ERROR([
15-Linking is badly borked on your system. Please ensure your library path is correct
16-Check config.log for details - check near the end of the log above 'failed program was'
17-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
18-prefix you're compiling on: '${prefix}' ]),
19-AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
20-LIBS="$dofus_save_libs"
21+dnl dofus_save_libs="$LIBS"
22+dnl LIBS="$ORBIT_LIBS $LIBS"
23+dnl AC_TRY_RUN([ #include <stdio.h>
24+dnl main ()
25+dnl {
26+dnl return 0;
27+dnl } ],,
28+dnl AC_MSG_ERROR([
29+dnl Linking is badly borked on your system. Please ensure your library path is correct
30+dnl Check config.log for details - check near the end of the log above 'failed program was'
31+dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
32+dnl prefix you're compiling on: '${prefix}' ]),
33+dnl AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
34+dnl LIBS="$dofus_save_libs"
35
36 orig_CPPFLAGS=$CPPFLAGS
37 CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"