summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb')
-rw-r--r--meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb b/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb
new file mode 100644
index 000000000..e86f75f0c
--- /dev/null
+++ b/meta-gnome/recipes-gnome/grilo/grilo_0.3.16.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Grilo is a framework forsearching media content from various sources"
2LICENSE = "LGPL-2.1-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
4
5DEPENDS = " \
6 libxml2 \
7 glib-2.0 \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11
12inherit gnomebase gobject-introspection gtk-doc gettext vala
13
14SRC_URI[archive.sha256sum] = "884580e8c5ece280df23aa63ff5234b7d48988a404df7d6bfccd1e77b473bd96"
15
16GIR_MESON_OPTION = "enable-introspection"
17GTKDOC_MESON_OPTION = "enable-gtk-doc"
18
19# Note: removing 'net' from PACKAGECONFIG causes
20# | bindings/vala/meson.build:15:0: ERROR: Unknown variable "grlnet_gir".
21PACKAGECONFIG ??= "net"
22
23PACKAGECONFIG[net] = "-Denable-grl-net=true, -Denable-grl-net=false, libsoup-3.0"
24PACKAGECONFIG[test-ui] = "-Denable-test-ui=true, -Denable-test-ui=false, gtk+3 liboauth"
25
26# Once we have a recipe for 'totem-plparser' this can turn into a PACKAGECONFIG
27EXTRA_OEMESON = "-Denable-grl-pls=false"
28
29do_compile:append() {
30 sed -i -e 's,${B}/../,,' ${B}/src/grl-type-builtins.h
31}