summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb86
1 files changed, 86 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb
new file mode 100644
index 000000000..ed86cbcb6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-shell/gnome-shell_46.1.bb
@@ -0,0 +1,86 @@
1SUMMARY = "GNOME Shell is the graphical shell of the GNOME desktop environment"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5
6DEPENDS = " \
7 libxml2-native \
8 gtk4 \
9 mutter \
10 evolution-data-server \
11 gcr \
12 geocode-glib \
13 gjs \
14 gnome-autoar \
15 gnome-desktop \
16 polkit \
17 pipewire \
18 libsoup-3.0 \
19 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', 'startup-notification', d)} \
20 ibus \
21 gsettings-desktop-schemas \
22"
23
24inherit gnomebase gsettings gettext gobject-introspection gtk-icon-cache features_check bash-completion
25
26REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
27
28GTKIC_VERSION = "4"
29GTKDOC_MESON_OPTION = "gtk_doc"
30GIR_MESON_OPTION = ""
31
32# gobject-introspection is mandatory and cannot be configured
33REQUIRED_DISTRO_FEATURES += "gobject-introspection-data"
34
35SRC_URI[archive.sha256sum] = "64f999844c101e63bf294d45b138de56319ad2f326282721aad0fa860653b369"
36SRC_URI += "file://0001-Introduce-options-gjs_path-to-optionally-set-path-to.patch"
37
38PACKAGECONFIG ??= "bluetooth nm ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
39PACKAGECONFIG[bluetooth] = ",,gnome-bluetooth"
40PACKAGECONFIG[nm] = "-Dnetworkmanager=true, -Dnetworkmanager=false,networkmanager libsecret,networkmanager"
41PACKAGECONFIG[systemd] = "-Dsystemd=true, -Dsystemd=false, systemd"
42
43EXTRA_OEMESON = " \
44 -Dgjs_path=${bindir}/gjs \
45 -Dextensions-app:gjs_path=${bindir}/gjs \
46 -Dtests=false \
47 -Dman=false \
48"
49
50do_install:append() {
51 # fix shebangs
52 for tool in `find ${D}${bindir} -name '*-tool'`; do
53 sed -i 's:#!${PYTHON}:#!${bindir}/python3:' $tool
54 done
55}
56
57GSETTINGS_PACKAGE = "${PN}-gsettings"
58
59FILES:${PN} += " \
60 ${datadir}/metainfo \
61 ${datadir}/dbus-1 \
62 ${datadir}/gnome-control-center \
63 ${datadir}/xdg-desktop-portal \
64 ${systemd_user_unitdir} \
65"
66
67RDEPENDS:${PN} += " \
68 accountsservice \
69 adwaita-icon-theme \
70 adwaita-icon-theme-cursors \
71 gdm-base \
72 gnome-control-center \
73 gnome-backgrounds \
74 gnome-bluetooth \
75 gnome-desktop \
76 gnome-session \
77 gnome-settings-daemon \
78 gnome-shell-gsettings \
79 gsettings-desktop-schemas \
80 librsvg-gtk \
81"
82
83PACKAGES =+ "${PN}-tools ${PN}-gsettings"
84FILES:${PN}-tools = "${bindir}/*-tool"
85RDEPENDS:${PN}-tools = "python3-core"
86