summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
new file mode 100644
index 000000000..cd8f43df6
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-session/gnome-session_2.32.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Gnome session manager"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5PR = "r3"
6
7SECTION = "x11/gnome"
8DEPENDS = "libxtst gtk+ glib-2.0 upower dbus-glib gconf pango gdk-pixbuf-native startup-notification"
9
10inherit gnome
11
12SRC_URI += "file://use_G_GINT64_FORMAT.patch"
13
14SRC_URI[archive.md5sum] = "222bad6b446cb19a6b9028ea24538002"
15SRC_URI[archive.sha256sum] = "22d93ce433fcf9c7ce6b5f36dd81f64e692ea0e41faaa0f61159ddac28c3686a"
16
17EXTRA_OECONF = " --with-gtk=2.0 ac_cv_path_GCONF_SANITY_CHECK=set --disable-docbook-docs"
18
19do_configure_append() {
20 for i in $(find ${S} -name "Makefile") ; do
21 sed -i -e s:"GCONFTOOL = .*/usr/bin/gconftool-2":"GCONFTOOL = /usr/bin/gconftool-2":g $i
22 sed -i -e s:"GCONF_SANITY_CHECK = set":"GCONF_SANITY_CHECK = /usr/libexec/gconf-sanity-check-2":g $i
23 done
24}
25
26RRECOMMENDS_${PN} += "${@base_contains('DISTRO_FEATURES', 'pam', 'pam-plugin-ck-connector', '', d)}"
27FILES_${PN} += "${datadir}/xsessions ${datadir}/icons ${datadir}/gnome ${libdir}/gnome-session/helpers"
28FILES_${PN}-dbg += "${libexecdir}/gnome-session/helpers/.debug"