summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-panel
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-panel')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch36
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel/idl-sysroot.patch22
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb49
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb37
4 files changed, 144 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch
new file mode 100644
index 000000000..378e3e405
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch
@@ -0,0 +1,36 @@
1From c65f1ae3472cfd4cd96fd376b7bbd95fba5eef0a Mon Sep 17 00:00:00 2001
2From: Vincent Untz <vuntz@gnome.org>
3Date: Fri, 27 May 2011 17:00:14 +0000
4Subject: build: Fix build with --as-needed
5
6upstream-status: backport
7
8---
9diff --git a/applets/notification_area/Makefile.am b/applets/notification_area/Makefile.am
10index 0afc6c5..9734536 100644
11--- a/applets/notification_area/Makefile.am
12+++ b/applets/notification_area/Makefile.am
13@@ -29,17 +29,17 @@ libtray_la_SOURCES = \
14 NOTIFICATION_AREA_SOURCES = main.c main.h
15
16 NOTIFICATION_AREA_LDADD = \
17+ libtray.la \
18 ../../libpanel-applet/libpanel-applet-4.la \
19 $(X_LIBS) \
20 $(NOTIFICATION_AREA_LIBS) \
21- $(LIBPANEL_APPLET_LIBS) \
22- libtray.la
23+ $(LIBPANEL_APPLET_LIBS)
24
25 testtray_SOURCES = testtray.c
26 testtray_LDADD = \
27+ libtray.la \
28 $(X_LIBS) \
29- $(NOTIFICATION_AREA_LIBS) \
30- libtray.la
31+ $(NOTIFICATION_AREA_LIBS)
32
33 if NOTIFICATION_AREA_INPROCESS
34 APPLET_IN_PROCESS = true
35--
36cgit v0.9
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/idl-sysroot.patch b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/idl-sysroot.patch
new file mode 100644
index 000000000..de4cd8486
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/idl-sysroot.patch
@@ -0,0 +1,22 @@
1--- /tmp/Makefile.am 2009-10-26 16:53:20.000000000 +0100
2+++ gnome-panel-2.28.0/gnome-panel/Makefile.am 2009-10-26 16:53:51.000000000 +0100
3@@ -43,7 +43,7 @@
4 $(NULL)
5
6 $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
7- $(AM_V_GEN)$(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
8+ $(AM_V_GEN)$(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
9
10 BUILT_SOURCES = \
11 $(CORBA_SRCLIST) \
12--- /tmp/Makefile.am 2009-10-26 16:54:17.000000000 +0100
13+++ gnome-panel-2.28.0/libpanel-applet/Makefile.am 2009-10-26 16:54:34.000000000 +0100
14@@ -45,7 +45,7 @@
15 GNOME_Panel.h
16
17 $(CORBA_SRCLIST): $(top_srcdir)/idl/GNOME_Panel.idl $(ORBIT_IDL)
18- $(AM_V_GEN)$(ORBIT_IDL) -I $(BONOBO_IDLDIR) -I $(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
19+ $(AM_V_GEN)$(ORBIT_IDL) -I $(SYSROOT)$(BONOBO_IDLDIR) -I $(SYSROOT)$(BONOBO_ACT_IDLDIR) $(top_srcdir)/idl/GNOME_Panel.idl
20
21 noinst_PROGRAMS = test-bonobo-applet
22
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb
new file mode 100644
index 000000000..8802dba1b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb
@@ -0,0 +1,49 @@
1SUMMARY = "GNOME panel"
2LICENSE = "GPLv2 & LGPLv2 & GFDLv1.1"
3
4BPN = "gnome-panel"
5PR = "r1"
6
7# conflicts with gnome-panel, because they provide the same package
8# http://patches.openembedded.org/patch/43105/
9EXCLUDE_FROM_WORLD = "1"
10DEFAULT_PREFERENCE = "-1"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \
14 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2"
15
16SECTION = "x11/gnome"
17
18DEPENDS = "gnome-doc-utils-native gtk+3 dconf gconf glib-2.0 gnome-desktop3 gtk+ pango libwnck3 gnome-menus cairo libgweather3 dbus-glib librsvg libcanberra"
19
20inherit gtk-doc gnome gettext pkgconfig
21
22SRC_URI += "file://as-needed.patch "
23
24SRC_URI[archive.md5sum] = "0f2f644dc4081b72f6df7a65282af7c6"
25SRC_URI[archive.sha256sum] = "25db8ec026c4bf47f0ef5cc7e2712f2aad175bd7fb8e4952ef5f8b200f17f196"
26
27EXTRA_OECONF = "--disable-scrollkeeper --disable-eds --enable-bonobo=no --with-in-process-applets=none"
28
29do_configure_prepend() {
30 gnome-doc-prepare --automake
31 sed -i -e s:help:: ${S}/Makefile.am
32}
33
34pkg_postinst_${PN}_append () {
35 gconftool-2 --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults \
36 --direct --load /etc/gconf/schemas/panel-default-setup.entries
37}
38
39PACKAGES =+ "libpanel-applet"
40FILES_libpanel-applet = "${libdir}/libpanel-applet-3.so.*"
41
42FILES_${PN} =+ "${datadir}/gnome* \
43 ${datadir}/dbus-1 \
44 ${datadir}/icons \
45 ${datadir}/PolicyKit \
46 ${libdir}/bonobo \
47"
48
49
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
new file mode 100644
index 000000000..4957a99aa
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
@@ -0,0 +1,37 @@
1SUMMARY = "GNOME panel"
2LICENSE = "GPLv2 & LGPLv2 & GFDLv1.1"
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \
6 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8SECTION = "x11/gnome"
9
10PR = "r7"
11
12DEPENDS = "gnome-doc-utils-native gconf glib-2.0 gnome-desktop gtk+ pango libwnck gnome-menus cairo libgweather dbus-glib librsvg libcanberra"
13
14inherit gtk-doc gnome autotools-brokensep gettext pkgconfig gconf
15
16SRCREV = "6a364b6a4a9beed3da9ca6f5b0dac81eb99dea2a"
17SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF = "--disable-scrollkeeper --disable-eds --enable-bonobo=no --with-in-process-applets=none"
22
23do_configure_prepend() {
24 gnome-doc-prepare --automake
25 sed -i -e s:help:: ${S}/Makefile.am
26 sed -i -e s:^#!@PYTHON@:#!/usr/bin/python: ${S}/gnome-panel/gnome-panel-add.in
27}
28
29PACKAGES =+ "libpanel-applet"
30FILES_libpanel-applet = "${libdir}/libpanel-applet-*.so.*"
31
32FILES_${PN} =+ "${datadir}/gnome* \
33 ${datadir}/dbus-1 \
34 ${datadir}/icons \
35 ${datadir}/PolicyKit \
36 ${libdir}/bonobo \
37"