summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
new file mode 100644
index 000000000..4957a99aa
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel_2.32.1.bb
@@ -0,0 +1,37 @@
1SUMMARY = "GNOME panel"
2LICENSE = "GPLv2 & LGPLv2 & GFDLv1.1"
3
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \
6 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2"
7
8SECTION = "x11/gnome"
9
10PR = "r7"
11
12DEPENDS = "gnome-doc-utils-native gconf glib-2.0 gnome-desktop gtk+ pango libwnck gnome-menus cairo libgweather dbus-glib librsvg libcanberra"
13
14inherit gtk-doc gnome autotools-brokensep gettext pkgconfig gconf
15
16SRCREV = "6a364b6a4a9beed3da9ca6f5b0dac81eb99dea2a"
17SRC_URI = "git://git.gnome.org/gnome-panel;branch=gnome-2-32"
18
19S = "${WORKDIR}/git"
20
21EXTRA_OECONF = "--disable-scrollkeeper --disable-eds --enable-bonobo=no --with-in-process-applets=none"
22
23do_configure_prepend() {
24 gnome-doc-prepare --automake
25 sed -i -e s:help:: ${S}/Makefile.am
26 sed -i -e s:^#!@PYTHON@:#!/usr/bin/python: ${S}/gnome-panel/gnome-panel-add.in
27}
28
29PACKAGES =+ "libpanel-applet"
30FILES_libpanel-applet = "${libdir}/libpanel-applet-*.so.*"
31
32FILES_${PN} =+ "${datadir}/gnome* \
33 ${datadir}/dbus-1 \
34 ${datadir}/icons \
35 ${datadir}/PolicyKit \
36 ${libdir}/bonobo \
37"