summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb
new file mode 100644
index 000000000..972a4d4db
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb
@@ -0,0 +1,51 @@
1SUMMARY = "GNOME panel"
2LICENSE = "GPLv2 & LGPLv2 & GFDLv1.1"
3
4BPN = "gnome-panel"
5PR = "r1"
6
7PNBLACKLIST[gnome-panel3] ?= "CONFLICT: depends on libgweather3 which conflicts with libgweather"
8
9# conflicts with gnome-panel, because they provide the same package
10# http://patches.openembedded.org/patch/43105/
11EXCLUDE_FROM_WORLD = "1"
12DEFAULT_PREFERENCE = "-1"
13
14LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
15 file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \
16 file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2"
17
18SECTION = "x11/gnome"
19
20DEPENDS = "gnome-doc-utils-native gtk+3 dconf gconf glib-2.0 gnome-desktop3 gtk+ pango libwnck3 gnome-menus cairo libgweather3 dbus-glib librsvg libcanberra"
21
22inherit gtk-doc gnome gettext pkgconfig
23
24SRC_URI += "file://as-needed.patch "
25
26SRC_URI[archive.md5sum] = "0f2f644dc4081b72f6df7a65282af7c6"
27SRC_URI[archive.sha256sum] = "25db8ec026c4bf47f0ef5cc7e2712f2aad175bd7fb8e4952ef5f8b200f17f196"
28
29EXTRA_OECONF = "--disable-scrollkeeper --disable-eds --enable-bonobo=no --with-in-process-applets=none"
30
31do_configure_prepend() {
32 gnome-doc-prepare --automake
33 sed -i -e s:help:: ${S}/Makefile.am
34}
35
36pkg_postinst_${PN}_append () {
37 gconftool-2 --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults \
38 --direct --load /etc/gconf/schemas/panel-default-setup.entries
39}
40
41PACKAGES =+ "libpanel-applet"
42FILES_libpanel-applet = "${libdir}/libpanel-applet-3.so.*"
43
44FILES_${PN} =+ "${datadir}/gnome* \
45 ${datadir}/dbus-1 \
46 ${datadir}/icons \
47 ${datadir}/PolicyKit \
48 ${libdir}/bonobo \
49"
50
51