summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch')
-rw-r--r--meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch
new file mode 100644
index 000000000..378e3e405
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel/as-needed.patch
@@ -0,0 +1,36 @@
1From c65f1ae3472cfd4cd96fd376b7bbd95fba5eef0a Mon Sep 17 00:00:00 2001
2From: Vincent Untz <vuntz@gnome.org>
3Date: Fri, 27 May 2011 17:00:14 +0000
4Subject: build: Fix build with --as-needed
5
6upstream-status: backport
7
8---
9diff --git a/applets/notification_area/Makefile.am b/applets/notification_area/Makefile.am
10index 0afc6c5..9734536 100644
11--- a/applets/notification_area/Makefile.am
12+++ b/applets/notification_area/Makefile.am
13@@ -29,17 +29,17 @@ libtray_la_SOURCES = \
14 NOTIFICATION_AREA_SOURCES = main.c main.h
15
16 NOTIFICATION_AREA_LDADD = \
17+ libtray.la \
18 ../../libpanel-applet/libpanel-applet-4.la \
19 $(X_LIBS) \
20 $(NOTIFICATION_AREA_LIBS) \
21- $(LIBPANEL_APPLET_LIBS) \
22- libtray.la
23+ $(LIBPANEL_APPLET_LIBS)
24
25 testtray_SOURCES = testtray.c
26 testtray_LDADD = \
27+ libtray.la \
28 $(X_LIBS) \
29- $(NOTIFICATION_AREA_LIBS) \
30- libtray.la
31+ $(NOTIFICATION_AREA_LIBS)
32
33 if NOTIFICATION_AREA_INPROCESS
34 APPLET_IN_PROCESS = true
35--
36cgit v0.9