summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.36.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.36.3.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.36.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.36.3.bb b/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.36.3.bb
new file mode 100644
index 000000000..6dd989415
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-flashback/gnome-flashback_3.36.3.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNOME Flashback (GNOME 2) session"
2LICENSE = "GPLv3"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4
5inherit gnomebase gsettings gtk-icon-cache gettext upstream-version-is-even features_check
6
7REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam"
8
9DEPENDS += " \
10 upower \
11 ibus \
12 libxkbfile \
13 polkit \
14 metacity \
15 gdm \
16 gnome-desktop3 \
17 gnome-bluetooth \
18 gnome-panel \
19"
20
21SRC_URI[archive.md5sum] = "690b0d78c7d9265183ef18387b12fa50"
22SRC_URI[archive.sha256sum] = "2dba9ea40f2da81c22954a8ccc29f8f1fa4ca8395a6bb552506635832751c1a7"
23
24do_install_append() {
25 # no oe-layer has compiz -> remove dead session
26 rm -f ${D}${datadir}/xsessions/gnome-flashback-compiz.desktop
27}
28
29FILES_${PN} += " \
30 ${datadir}/desktop-directories \
31 ${datadir}/gnome-panel \
32 ${datadir}/gnome-session \
33 ${datadir}/xsessions \
34 ${libdir}/gnome-panel \
35 ${systemd_user_unitdir} \
36"
37
38RDEPENDS_${PN} += "metacity"