summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gedit/gedit_42.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gedit/gedit_42.1.bb')
-rw-r--r--meta-gnome/recipes-gnome/gedit/gedit_42.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gedit/gedit_42.1.bb b/meta-gnome/recipes-gnome/gedit/gedit_42.1.bb
new file mode 100644
index 000000000..e2bbf1889
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gedit/gedit_42.1.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GNOME editor"
2SECTION = "x11/gnome"
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8DEPENDS = " \
9 gdk-pixbuf-native \
10 gtk+3 \
11 gsettings-desktop-schemas \
12 libpeas \
13 libsoup-2.4 \
14 gspell \
15 gtksourceview4 \
16 tepl \
17"
18
19inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
23
24SRC_URI[archive.sha256sum] = "7f1fd43df5110d4c37de6541993f41f0fbc3efc790900e92053479ba069920e9"
25
26# gobject-introspection is mandatory and cannot be configured
27# x11 is needed for tepl and gtksourceview4
28REQUIRED_DISTRO_FEATURES = "gobject-introspection-data x11"
29GIR_MESON_OPTION = ""
30
31GTKDOC_MESON_OPTION = "gtk_doc"
32
33PACKAGES += "${PN}-python"
34
35FILES:${PN} += " \
36 ${datadir}/dbus-1 \
37 ${datadir}/metainfo \
38"
39
40FILES:${PN}-python += " \
41 ${PYTHON_SITEPACKAGES_DIR} \
42"
43
44RDEPENDS:${PN} += "gsettings-desktop-schemas"
45RRECOMMENDS:${PN} += "source-code-pro-fonts"