summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb')
-rw-r--r--meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb b/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb
new file mode 100644
index 000000000..dbaae649e
--- /dev/null
+++ b/meta-gnome/recipes-gnome/faenza-icon-theme/faenza-icon-theme_1.3.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "An icon theme for Gnome"
2SECTION = "x11/wm"
3LICENSE = "GPLv3"
4HOMEPAGE = "http://code.google.com/p/faenza-icon-theme/"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7inherit allarch gtk-icon-cache
8
9S = "${WORKDIR}"
10
11SRC_URI = "http://faenza-icon-theme.googlecode.com/files/${PN}_${PV}.zip"
12SRC_URI[md5sum] = "e9bd6106d13017ce06d24b586259ae9c"
13SRC_URI[sha256sum] = "d4486fda0413f8a81a87e0dd2329f50f2a8a7cb4147b48cf147f0160add8174a"
14
15do_install() {
16 install -d ${D}${datadir}/icons
17 for theme in `find -name 'Faenza*.tar.gz'`; do
18 tar -xf ${theme} -C ${D}${datadir}/icons
19 done
20 tar -xf emesene-faenza-theme.tar.gz -C ${D}${datadir}
21 mv -f ${D}${datadir}/emesene/themes ${D}${datadir}/themes
22 rm -rf ${D}${datadir}/emesene
23}
24
25FILES_${PN} += "${datadir}/icons ${datadir}/themes"