summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb')
-rw-r--r--meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb112
1 files changed, 112 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
new file mode 100644
index 000000000..7c935a3d5
--- /dev/null
+++ b/meta-gnome/recipes-gnome/eds/evolution-data-server_git.bb
@@ -0,0 +1,112 @@
1SUMMARY = "Evolution database backend server"
2HOMEPAGE = "http://www.gnome.org/projects/evolution/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "LGPLv2 & LGPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=6a6e689d19255cf0557f3fe7d7068212 \
7 file://camel/camel.h;endline=24;md5=b02175c88f821224746b347a89731a2b \
8 file://libedataserver/e-data-server-util.h;endline=20;md5=934502f03c84523aa059d4825887b380 \
9 file://calendar/libecal/e-cal.h;endline=24;md5=5d496b9b6fd2a4fdbbfc31ef9455c9d0"
10
11DEPENDS = "intltool-native glib-2.0 gtk+3 gconf dbus db gnome-common virtual/libiconv zlib libsoup-2.4 libglade libical libgnome-keyring gperf-native libgdata nss"
12
13SRCREV = "a9e4e74ec4473a4fd09e56b690bd4fa72f686687"
14
15# 3.4 series needs libgdata-0.10*, 3.8 series needs also libsecret instead of gnome-keyring
16PV = "3.2.3+git${SRCPV}"
17
18SRC_URI = " \
19 git://git.gnome.org/evolution-data-server;branch=gnome-3-2 \
20 file://0001-contact-Replace-the-Novell-sample-contact-with-somet.patch \
21 file://0002-Fix-for-automake-1.12.x.patch \
22 file://0003-Disable-Werror-for-automake.patch \
23 file://0004-configure-Fix-libical-pkg-config-trying-to-use-host-.patch \
24 file://0005-soup-adapt-to-new-libxml2-API-from-2.9.0.patch \
25 file://iconv-detect.h \
26"
27
28S = "${WORKDIR}/git"
29
30inherit autotools gtk-doc pkgconfig gettext
31
32# -ldb needs this on some platforms
33LDFLAGS += "-lpthread"
34
35# Parallel make shows many issues with this source code.
36# Current problems seem to be duplicate execution of the calander/backends
37# directories by make resulting in truncated/corrupt .la files
38#PARALLEL_MAKE = ""
39
40do_configure_append () {
41 cp ${WORKDIR}/iconv-detect.h ${S}
42}
43
44EXTRA_OECONF = "--without-openldap \
45 --with-libdb=${STAGING_DIR_HOST}${prefix} \
46 --disable-nntp --disable-goa --disable-weather"
47
48PACKAGES =+ "libcamel libcamel-dev libebook libebook-dev libecal libecal-dev \
49 libedata-book libedata-book-dev libedata-cal libedata-cal-dev \
50 libedataserver libedataserver-dev \
51 libedataserverui libedataserverui-dev"
52
53FILES_${PN} =+ "${datadir}/evolution-data-server-*/ui/"
54FILES_${PN}-dev =+ "${libdir}/pkgconfig/evolution-data-server-*.pc"
55FILES_${PN}-dbg =+ "${libdir}/evolution-data-server*/camel-providers/.debug \
56 ${libdir}/evolution-data-server*/calendar-backends/.debug \
57 ${libdir}/evolution-data-server*/addressbook-backends/.debug \
58 ${libdir}/evolution-data-server*/extensions/.debug/"
59
60RRECOMMENDS_${PN}-dev += "libecal-dev libebook-dev"
61
62FILES_libcamel = "${libdir}/libcamel-*.so.* \
63 ${libdir}/libcamel-provider-*.so.* \
64 ${libdir}/evolution-data-server*/camel-providers/*.so \
65 ${libdir}/evolution-data-server*/camel-providers/*.urls"
66FILES_libcamel-dev = "${libdir}/libcamel-*.so ${libdir}/libcamel-provider-*.so \
67 ${libdir}/pkgconfig/camel*pc \
68 ${libdir}/evolution-data-server*/camel-providers/*.la \
69 ${includedir}/evolution-data-server*/camel"
70
71FILES_libebook = "${libdir}/libebook-*.so.*"
72FILES_libebook-dev = "${libdir}/libebook-1.2.so \
73 ${libdir}/pkgconfig/libebook-*.pc \
74 ${includedir}/evolution-data-server*/libebook/*.h"
75RRECOMMENDS_libebook = "libedata-book"
76
77FILES_libecal = "${libdir}/libecal-*.so.* \
78 ${datadir}/evolution-data-server-1.4/zoneinfo"
79FILES_libecal-dev = "${libdir}/libecal-*.so ${libdir}/pkgconfig/libecal-*.pc \
80 ${includedir}/evolution-data-server*/libecal/*.h \
81 ${includedir}/evolution-data-server*/libical/*.h"
82RRECOMMENDS_libecal = "libedata-cal tzdata"
83
84FILES_libedata-book = "${libexecdir}/e-addressbook-factory \
85 ${datadir}/dbus-1/services/*.AddressBook.service \
86 ${libdir}/libedata-book-*.so.* \
87 ${libdir}/evolution-data-server-*/extensions/libebook*.so \
88 ${datadir}/evolution-data-server-1.4/weather/Locations.xml"
89FILES_libedata-book-dev = "${libdir}/libedata-book-*.so \
90 ${libdir}/pkgconfig/libedata-book-*.pc \
91 ${libdir}/evolution-data-server-*/extensions/libebook*.la \
92 ${includedir}/evolution-data-server-*/libedata-book"
93
94FILES_libedata-cal = "${libexecdir}/e-calendar-factory \
95 ${datadir}/dbus-1/services/*.Calendar.service \
96 ${libdir}/libedata-cal-*.so.* \
97 ${libdir}/evolution-data-server-*/extensions/libecal*.so"
98FILES_libedata-cal-dev = "${libdir}/libedata-cal-*.so \
99 ${libdir}/pkgconfig/libedata-cal-*.pc \
100 ${includedir}/evolution-data-server-*/libedata-cal \
101 ${libdir}/evolution-data-server-*/extensions/libecal*.la"
102
103FILES_libedataserver = "${libdir}/libedataserver-*.so.*"
104FILES_libedataserver-dev = "${libdir}/libedataserver-*.so \
105 ${libdir}/pkgconfig/libedataserver-*.pc \
106 ${includedir}/evolution-data-server-*/libedataserver/*.h"
107
108FILES_libedataserverui = "${libdir}/libedataserverui-*.so.* ${datadir}/evolution-data-server-1.4/glade/*.glade"
109FILES_libedataserverui-dev = "${libdir}/libedataserverui-*.so \
110 ${libdir}/pkgconfig/libedataserverui-*.pc \
111 ${includedir}/evolution-data-server-*/libedataserverui/*.h"
112