summaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb127
1 files changed, 127 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
new file mode 100644
index 000000000..eb4bba217
--- /dev/null
+++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.0.bb
@@ -0,0 +1,127 @@
1SUMMARY = "AbiWord is free word processing program similar to Microsoft(r) Word"
2HOMEPAGE = "http://www.abiword.org"
3SECTION = "x11/office"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=ecd3ac329fca77e2d0e412bec38e1c20"
6DEPENDS = "perl-native wv libglade libfribidi jpeg libpng \
7 librsvg libwmf-native gtkmathview asio gtk+ evolution-data-server"
8RDEPENDS_${PN} = "glibc-gconv-ibm850 glibc-gconv-cp1252 \
9 glibc-gconv-iso8859-15 glibc-gconv-iso8859-1"
10RCONFLICTS_${PN} = "${PN}-embedded"
11
12SRC_URI = "http://www.abisource.com/downloads/${BPN}/${PV}/source/${BP}.tar.gz \
13 file://debian_patches_boost54.patch \
14 file://autogen-common.sh \
15"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=c5edcc3ccd864b19004d14e9c1c9a26a"
18
19SRC_URI[md5sum] = "8d9c41cff3a8fbef8d0c835c65600e65"
20SRC_URI[sha256sum] = "d17e318c00ff4eb353e0e7994b098b1d4f9ddd8712ac0261a0e38b89081fac01"
21
22#want 3.x from 3.x.y for the installation directory
23SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
24
25inherit autotools-brokensep pkgconfig
26
27PACKAGECONFIG ??= "collab-backend-xmpp collab-backend-tcp"
28PACKAGECONFIG[spell] = "--enable-spell,--disable-spell,enchant"
29PACKAGECONFIG[collab-backend-xmpp] = "--enable-collab-backend-xmpp,--disable-collab-backend-xmpp,libgsf libxml2 loudmouth"
30PACKAGECONFIG[collab-backend-tcp] = "--enable-collab-backend-tcp,--disable-collab-backend-tcp,libgsf libxml2"
31PACKAGECONFIG[collab-backend-service] = "--enable-collab-backend-service,--disable-collab-backend-service,libgsf libxml2 libsoup-2.4 gnutls"
32PACKAGECONFIG[collab-backend-telepathy] = "--enable-collab-backend-telepathy,--disable-collab-backend-telepathy,libgsf libxml2 telepathy-glib telepathy-mission-control"
33PACKAGECONFIG[collab-backend-sugar] = "--enable-collab-backend-sugar,--disable-collab-backend-sugar,libgsf libxml2 dbus-glib"
34
35EXTRA_OECONF = " --disable-static \
36 --enable-plugins \
37 --enable-clipart \
38 --enable-templates \
39 --without-gnomevfs \
40 --with-gtk2 \
41 --with-libwmf-config=${STAGING_DIR} \
42"
43
44# AbiWord configure.ac does not play nicely with autoreconf
45# so use the autogen.sh script that comes with AbiWord
46do_configure() {
47 install -m 0755 ${WORKDIR}/autogen-common.sh ${B}/autogen-common.sh
48 ./autogen-common.sh
49 autotools_do_configure
50}
51
52do_compile() {
53 cd goffice-bits2
54 make goffice-paths.h
55 make libgoffice.la
56 cd ${B}
57 oe_runmake
58}
59
60PACKAGES += " ${PN}-clipart ${PN}-strings ${PN}-systemprofiles ${PN}-templates "
61
62FILES_${PN} += " \
63 ${libdir}/lib${PN}-*.so \
64 ${datadir}/mime-info \
65 ${datadir}/icons/* \
66 ${datadir}/${PN}-${SHRT_VER}/glade \
67 ${datadir}/${PN}-${SHRT_VER}/scripts \
68 ${datadir}/${PN}-${SHRT_VER}/system.profile-en \
69 ${datadir}/${PN}-${SHRT_VER}/system.profile-en_GB \
70 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt \
71 ${datadir}/${PN}-${SHRT_VER}/templates/normal.awt-en_GB \
72 ${datadir}/${PN}-${SHRT_VER}/templates/Employee-Directory.awt \
73 ${datadir}/${PN}-${SHRT_VER}/templates/Business-Report.awt \
74 ${datadir}/${PN}-${SHRT_VER}/templates/Fax-Coversheet.awt \
75 ${datadir}/${PN}-${SHRT_VER}/templates/Resume.awt \
76 ${datadir}/${PN}-${SHRT_VER}/templates/Two-Columns.awt \
77 ${datadir}/${PN}-${SHRT_VER}/templates/Memo.awt \
78 ${datadir}/${PN}-${SHRT_VER}/templates/Press-Release.awt \
79 ${datadir}/${PN}-${SHRT_VER}/certs \
80 ${datadir}/${PN}-${SHRT_VER}/ui \
81 ${datadir}/${PN}-${SHRT_VER}/xsl* \
82 ${datadir}/${PN}-${SHRT_VER}/mime-info \
83 ${datadir}/${PN}-${SHRT_VER}/Pr*.xml \
84"
85
86# don't steal /usr/lib/libabiword-3.0.so from ${PN}
87# in this case it's needed in ${PN}
88FILES_${PN}-dev = " \
89 ${includedir} \
90 ${libdir}/pkgconfig \
91 ${libdir}/${PN}*.la \
92 ${libdir}/lib${PN}*.la \
93 ${libdir}/${PN}-${SHRT_VER}/plugins/*.la \
94"
95FILES_${PN}-dbg += "${libdir}/${PN}-${SHRT_VER}/plugins/.debug"
96FILES_${PN}-doc += "${datadir}/${PN}-*/readme*"
97
98FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/strings"
99FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/system.profile*"
100FILES_${PN}-clipart += "${datadir}/${PN}-${SHRT_VER}/clipart"
101FILES_${PN}-strings += "${datadir}/${PN}-${SHRT_VER}/AbiWord/strings"
102FILES_${PN}-systemprofiles += "${datadir}/${PN}-${SHRT_VER}/AbiWord/system.profile*"
103FILES_${PN}-templates += "${datadir}/${PN}-${SHRT_VER}/templates"
104
105PACKAGES_DYNAMIC += "^${PN}-meta.* ^${PN}-plugin-.*"
106
107python populate_packages_prepend () {
108 abiword_libdir = d.expand('${libdir}/${PN}-${SHRT_VER}/plugins')
109 do_split_packages(d, abiword_libdir, '(.*)\.so$', 'abiword-plugin-%s', 'Abiword plugin for %s', extra_depends='')
110
111 metapkg = "abiword-meta"
112 d.setVar('ALLOW_EMPTY_' + metapkg, "1")
113 d.setVar('FILES_' + metapkg, "")
114 blacklist = [ 'abiword-plugins-dbg', 'abiword-plugins', 'abiword-plugins-doc', 'abiword-plugins-dev', 'abiword-plugins-locale' ]
115 metapkg_rdepends = []
116 packages = d.getVar('PACKAGES', 1).split()
117 for pkg in packages[1:]:
118 if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"):
119 print "Modifying ", pkg
120 metapkg_rdepends.append(pkg)
121 d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends))
122 d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package')
123 packages.append(metapkg)
124 d.setVar('PACKAGES', ' '.join(packages))
125}
126
127FILES_${PN}-plugin-openxml += "${datadir}/${PN}-${SHRT_VER}/omml_xslt"