summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb')
-rw-r--r--meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb20
1 files changed, 14 insertions, 6 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
index 33d441e41..711637a70 100644
--- a/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
+++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2024.01.14.bb
@@ -16,6 +16,7 @@ SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19# brokensep because m4/package_globals.m4 calls ". ./VERSION" (and that's not the only issue)
19inherit autotools-brokensep useradd 20inherit autotools-brokensep useradd
20 21
21DEPENDS += "xfsprogs acl" 22DEPENDS += "xfsprogs acl"
@@ -44,15 +45,22 @@ USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2"
44EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root" 45EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root"
45 46
46TARGET_CC_ARCH:append:libc-musl = " -D_LARGEFILE64_SOURCE" 47TARGET_CC_ARCH:append:libc-musl = " -D_LARGEFILE64_SOURCE"
47# install-sh script in the project is outdated 48
48# we use the one from the latest libtool to solve installation issues
49# It looks like the upstream is not interested in having it fixed :(
50# https://www.spinics.net/lists/fstests/msg16981.html
51do_configure:prepend() { 49do_configure:prepend() {
52 cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B} 50 # this is done by Makefile configure target, but we don't call it in do_configure
51 cp -a ${S}/include/install-sh .
53} 52}
54 53
55do_install:append() { 54# Not sure if this is needed, but with old install-sh it was sometimes failing with:
55# cp: cannot stat 'group.list': No such file or directory
56# http://errors.yoctoproject.org/Errors/Details/752404/
57# PARALLEL_MAKEINST = "-j1"
58
59do_install:prepend() {
60 # otherwise install-sh duplicates DESTDIR prefix
61 export DIST_ROOT="/" DIST_MANIFEST="" DESTDIR="${D}"
62 oe_runmake install
63
56 unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite 64 unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite
57 install -d ${D}/usr/xfstests/unionmount-testsuite/tests 65 install -d ${D}/usr/xfstests/unionmount-testsuite/tests
58 install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests 66 install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests