diff options
Diffstat (limited to 'meta-filesystems/recipes-utils/xfstests/xfstests_2022.11.06.bb')
-rw-r--r-- | meta-filesystems/recipes-utils/xfstests/xfstests_2022.11.06.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-utils/xfstests/xfstests_2022.11.06.bb b/meta-filesystems/recipes-utils/xfstests/xfstests_2022.11.06.bb new file mode 100644 index 000000000..1c1a176a6 --- /dev/null +++ b/meta-filesystems/recipes-utils/xfstests/xfstests_2022.11.06.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "File system QA test suite" | ||
2 | LICENSE = "GPL-2.0-only" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=74274e8a218423e49eefdea80bc55038" | ||
4 | |||
5 | SRCREV_FORMAT = "xfstests_unionmount" | ||
6 | |||
7 | SRC_URI = "git://git.kernel.org/pub/scm/fs/xfs/xfstests-dev.git;branch=master;name=xfstests \ | ||
8 | git://github.com/amir73il/unionmount-testsuite.git;branch=master;protocol=https;name=unionmount;destsuffix=unionmount-testsuite \ | ||
9 | file://0001-Add-a-return-type-to-aio_rw.patch \ | ||
10 | file://0002-Drop-detached_mounts_propagation-and-remove-sys-moun.patch \ | ||
11 | " | ||
12 | |||
13 | SRCREV_xfstests = "41f2bbdec5faa5d6522e86e63c1f30473a99dbfe" | ||
14 | SRCREV_unionmount = "e3825b16b46f4c4574a1a69909944c059835f914" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit autotools-brokensep useradd | ||
19 | |||
20 | DEPENDS += "xfsprogs acl" | ||
21 | RDEPENDS:${PN} += "\ | ||
22 | bash \ | ||
23 | bc \ | ||
24 | coreutils \ | ||
25 | e2fsprogs \ | ||
26 | e2fsprogs-tune2fs \ | ||
27 | e2fsprogs-resize2fs \ | ||
28 | libaio \ | ||
29 | libcap-bin \ | ||
30 | overlayfs-progs \ | ||
31 | perl \ | ||
32 | python3 \ | ||
33 | python3-core \ | ||
34 | xfsprogs \ | ||
35 | acl \ | ||
36 | " | ||
37 | |||
38 | USERADD_PACKAGES = "${PN}" | ||
39 | # these users are necessary to run the tests | ||
40 | USERADD_PARAM:${PN} = "-U -m fsgqa; -N 123456-fsgqa; -N fsgqa2" | ||
41 | |||
42 | EXTRA_OECONF = "INSTALL_USER=root INSTALL_GROUP=root" | ||
43 | |||
44 | # install-sh script in the project is outdated | ||
45 | # we use the one from the latest libtool to solve installation issues | ||
46 | # It looks like the upstream is not interested in having it fixed :( | ||
47 | # https://www.spinics.net/lists/fstests/msg16981.html | ||
48 | do_configure:prepend() { | ||
49 | cp ${STAGING_DIR_NATIVE}${datadir}/libtool/build-aux/install-sh ${B} | ||
50 | } | ||
51 | |||
52 | do_install:append() { | ||
53 | unionmount_target_dir=${D}/usr/xfstests/unionmount-testsuite | ||
54 | install -d ${D}/usr/xfstests/unionmount-testsuite/tests | ||
55 | install -D ${WORKDIR}/unionmount-testsuite/tests/* -t $unionmount_target_dir/tests | ||
56 | install ${WORKDIR}/unionmount-testsuite/*.py -t $unionmount_target_dir | ||
57 | install ${WORKDIR}/unionmount-testsuite/run -t $unionmount_target_dir | ||
58 | install ${WORKDIR}/unionmount-testsuite/README -t $unionmount_target_dir | ||
59 | } | ||
60 | |||
61 | FILES:${PN} += "\ | ||
62 | /usr/xfstests \ | ||
63 | " | ||