summaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb')
-rw-r--r--meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb b/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb
new file mode 100644
index 000000000..358b58eb5
--- /dev/null
+++ b/meta-filesystems/recipes-support/fuse/fuse_2.9.3.bb
@@ -0,0 +1,43 @@
1SUMMARY = "With FUSE it is possible to implement a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3programs to export a virtual filesystem to the Linux kernel. FUSE \
4also aims to provide a secure method for non privileged users to \
5create and mount their own filesystem implementations. \
6"
7HOMEPAGE = "http://fuse.sf.net"
8SECTION = "libs"
9LICENSE = "GPLv2 & LGPLv2"
10LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
11 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/fuse/fuse-${PV}.tar.gz \
14 file://gold-unversioned-symbol.patch \
15 file://aarch64.patch \
16"
17SRC_URI[md5sum] = "33cae22ca50311446400daf8a6255c6a"
18SRC_URI[sha256sum] = "0beb83eaf2c5e50730fc553406ef124d77bc02c64854631bdfc86bfd6437391c"
19
20inherit autotools pkgconfig
21
22EXTRA_OECONF = "--disable-kernel-module"
23
24PACKAGES =+ "fuse-utils-dbg fuse-utils libulockmgr libulockmgr-dev libulockmgr-dbg"
25
26RRECOMMENDS_${PN} = "kernel-module-fuse"
27
28FILES_${PN} += "${libdir}/libfuse.so.*"
29FILES_${PN}-dev += "${libdir}/libfuse*.la"
30
31FILES_libulockmgr = "${libdir}/libulockmgr.so.*"
32FILES_libulockmgr-dev += "${libdir}/libulock*.la"
33FILES_libulockmgr-dbg += "${libdir}/.debug/libulock*"
34
35# Forbid auto-renaming to libfuse-utils
36FILES_fuse-utils = "${bindir} ${base_sbindir}"
37FILES_fuse-utils-dbg = "${bindir}/.debug ${base_sbindir}/.debug"
38DEBIAN_NOAUTONAME_fuse-utils = "1"
39DEBIAN_NOAUTONAME_fuse-utils-dbg = "1"
40
41do_install_append() {
42 rm -rf ${D}${base_prefix}/dev
43}