diff options
-rw-r--r-- | meta-python/recipes-devtools/python/python-coloredlogs.inc | 24 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb | 26 |
2 files changed, 24 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-coloredlogs.inc b/meta-python/recipes-devtools/python/python-coloredlogs.inc deleted file mode 100644 index bdb1d752c..000000000 --- a/meta-python/recipes-devtools/python/python-coloredlogs.inc +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | DESCRIPTION = "Colored terminal output for Python's logging module" | ||
2 | HOMEPAGE = "https://coloredlogs.readthedocs.io" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=690da298a43805797a4fa7bbe180b3c6" | ||
6 | |||
7 | SRC_URI[md5sum] = "0a186966a1955fff8cf9489373e691d9" | ||
8 | SRC_URI[sha256sum] = "b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36" | ||
9 | |||
10 | inherit pypi | ||
11 | |||
12 | do_compile_prepend() { | ||
13 | sed -ie "s/find_pth_directory(),/'',/g" ${S}/setup.py | ||
14 | } | ||
15 | |||
16 | do_install_append() { | ||
17 | rm -rf ${D}${datadir} | ||
18 | } | ||
19 | |||
20 | RDEPENDS_${PN} += "\ | ||
21 | ${PYTHON_PN}-humanfriendly \ | ||
22 | " | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||
diff --git a/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb b/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb index 387239966..88fac87c7 100644 --- a/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb +++ b/meta-python/recipes-devtools/python/python3-coloredlogs_10.0.bb | |||
@@ -1,2 +1,24 @@ | |||
1 | inherit setuptools3 | 1 | DESCRIPTION = "Colored terminal output for Python's logging module" |
2 | require python-coloredlogs.inc | 2 | HOMEPAGE = "https://coloredlogs.readthedocs.io" |
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=690da298a43805797a4fa7bbe180b3c6" | ||
6 | |||
7 | SRC_URI[md5sum] = "0a186966a1955fff8cf9489373e691d9" | ||
8 | SRC_URI[sha256sum] = "b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36" | ||
9 | |||
10 | inherit pypi setuptools3 | ||
11 | |||
12 | do_compile_prepend() { | ||
13 | sed -ie "s/find_pth_directory(),/'',/g" ${S}/setup.py | ||
14 | } | ||
15 | |||
16 | do_install_append() { | ||
17 | rm -rf ${D}${datadir} | ||
18 | } | ||
19 | |||
20 | RDEPENDS_${PN} += "\ | ||
21 | ${PYTHON_PN}-humanfriendly \ | ||
22 | " | ||
23 | |||
24 | BBCLASSEXTEND = "native" | ||