diff options
-rw-r--r-- | meta-oe/recipes-graphics/openbox/files/0001-Fix-function-protype-visibility.patch | 94 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/openbox/obconf_git.bb | 1 |
2 files changed, 95 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/openbox/files/0001-Fix-function-protype-visibility.patch b/meta-oe/recipes-graphics/openbox/files/0001-Fix-function-protype-visibility.patch new file mode 100644 index 0000000000..344c5d149b --- /dev/null +++ b/meta-oe/recipes-graphics/openbox/files/0001-Fix-function-protype-visibility.patch | |||
@@ -0,0 +1,94 @@ | |||
1 | From 941d5ff3426e68cb9bcb4ae86066124cb2535b69 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 2 Sep 2022 12:32:20 -0700 | ||
4 | Subject: [PATCH] Fix function protype visibility | ||
5 | |||
6 | Include ctye.h for toupper | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/appearance.c | 1 + | ||
12 | src/desktops.c | 2 +- | ||
13 | src/desktops.h | 2 +- | ||
14 | src/main.c | 1 + | ||
15 | src/moveresize.c | 2 +- | ||
16 | src/moveresize.h | 2 +- | ||
17 | 6 files changed, 6 insertions(+), 4 deletions(-) | ||
18 | |||
19 | diff --git a/src/appearance.c b/src/appearance.c | ||
20 | index 4fb3f0c..ee55661 100644 | ||
21 | --- a/src/appearance.c | ||
22 | +++ b/src/appearance.c | ||
23 | @@ -20,6 +20,7 @@ | ||
24 | #include "main.h" | ||
25 | #include "tree.h" | ||
26 | #include "preview_update.h" | ||
27 | +#include <ctype.h> /* for toupper */ | ||
28 | |||
29 | static gboolean mapping = FALSE; | ||
30 | |||
31 | diff --git a/src/desktops.c b/src/desktops.c | ||
32 | index 8297f00..27ca514 100644 | ||
33 | --- a/src/desktops.c | ||
34 | +++ b/src/desktops.c | ||
35 | @@ -38,7 +38,7 @@ static void on_desktop_names_cell_edited(GtkCellRendererText *cell, | ||
36 | gpointer data); | ||
37 | static void enable_stuff(); | ||
38 | |||
39 | -void desktops_setup_tab() | ||
40 | +void desktops_setup_tab(void) | ||
41 | { | ||
42 | GtkWidget *w; | ||
43 | GtkCellRenderer *render; | ||
44 | diff --git a/src/desktops.h b/src/desktops.h | ||
45 | index 1ba3e36..446bfbb 100644 | ||
46 | --- a/src/desktops.h | ||
47 | +++ b/src/desktops.h | ||
48 | @@ -24,5 +24,5 @@ | ||
49 | |||
50 | void desktops_setup_num(GtkWidget *w); | ||
51 | void desktops_setup_names(GtkWidget *w); | ||
52 | - | ||
53 | +void desktops_setup_tab(void); | ||
54 | #endif | ||
55 | diff --git a/src/main.c b/src/main.c | ||
56 | index d7e3446..0176035 100644 | ||
57 | --- a/src/main.c | ||
58 | +++ b/src/main.c | ||
59 | @@ -28,6 +28,7 @@ | ||
60 | #include "dock.h" | ||
61 | #include "preview_update.h" | ||
62 | #include "gettext.h" | ||
63 | +#include "moveresize.h" | ||
64 | |||
65 | #include <gdk/gdkx.h> | ||
66 | #define SN_API_NOT_YET_FROZEN | ||
67 | diff --git a/src/moveresize.c b/src/moveresize.c | ||
68 | index c6fb3dd..bb52729 100644 | ||
69 | --- a/src/moveresize.c | ||
70 | +++ b/src/moveresize.c | ||
71 | @@ -37,7 +37,7 @@ static gboolean mapping = FALSE; | ||
72 | static void enable_stuff(); | ||
73 | static void write_fixed_position(const gchar *coord); | ||
74 | |||
75 | -void moveresize_setup_tab() | ||
76 | +void moveresize_setup_tab(void) | ||
77 | { | ||
78 | GtkWidget *w, *w1, *w2, *w3; | ||
79 | GtkSizeGroup *group; | ||
80 | diff --git a/src/moveresize.h b/src/moveresize.h | ||
81 | index 82ecc96..8faf526 100644 | ||
82 | --- a/src/moveresize.h | ||
83 | +++ b/src/moveresize.h | ||
84 | @@ -20,6 +20,6 @@ | ||
85 | #ifndef obconf__moveresize_h | ||
86 | #define obconf__moveresize_h | ||
87 | |||
88 | -void moveresize_setup_tab(); | ||
89 | +void moveresize_setup_tab(void); | ||
90 | |||
91 | #endif | ||
92 | -- | ||
93 | 2.37.3 | ||
94 | |||
diff --git a/meta-oe/recipes-graphics/openbox/obconf_git.bb b/meta-oe/recipes-graphics/openbox/obconf_git.bb index 772347190d..053af5a770 100644 --- a/meta-oe/recipes-graphics/openbox/obconf_git.bb +++ b/meta-oe/recipes-graphics/openbox/obconf_git.bb | |||
@@ -14,6 +14,7 @@ PV = "2.0.4+git${SRCPV}" | |||
14 | SRCREV = "63ec47c5e295ad4f09d1df6d92afb7e10c3fec39" | 14 | SRCREV = "63ec47c5e295ad4f09d1df6d92afb7e10c3fec39" |
15 | SRC_URI = " \ | 15 | SRC_URI = " \ |
16 | git://git.openbox.org/dana/obconf;branch=master \ | 16 | git://git.openbox.org/dana/obconf;branch=master \ |
17 | file://0001-Fix-function-protype-visibility.patch \ | ||
17 | " | 18 | " |
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |