summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch37
-rw-r--r--meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.8.bb (renamed from meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb)3
2 files changed, 1 insertions, 39 deletions
diff --git a/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch b/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
deleted file mode 100644
index bfe2412b5d..0000000000
--- a/meta-oe/recipes-extended/redis-plus-plus/files/0001-include-cstdint.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From e74bb5a7ef87e697571181280e6108b89104c02d Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 25 Jan 2023 20:40:56 -0800
4Subject: [PATCH] include <cstdint>
5
6gcc 13 libstdc++ moved some includes around and as a result <cstdint>
7is no longer transitively included [1]. Explicitly include it for uintXX_t.
8
9Fixes
10
11../git/src/sw/redis++/utils.h:187:1: error: 'uint16_t' does not name a type
12 187 | uint16_t crc16(const char *buf, int len);
13 | ^~~~~~~~
14
15[1] https://gcc.gnu.org/gcc-13/porting_to.html#header-dep-changes
16
17Upstream-Status: Submitted [https://github.com/sewenew/redis-plus-plus/pull/449]
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
19---
20 src/sw/redis++/utils.h | 1 +
21 1 file changed, 1 insertion(+)
22
23diff --git a/src/sw/redis++/utils.h b/src/sw/redis++/utils.h
24index f77f796..ff38f2d 100644
25--- a/src/sw/redis++/utils.h
26+++ b/src/sw/redis++/utils.h
27@@ -17,6 +17,7 @@
28 #ifndef SEWENEW_REDISPLUSPLUS_UTILS_H
29 #define SEWENEW_REDISPLUSPLUS_UTILS_H
30
31+#include <cstdint>
32 #include <cstring>
33 #include <string>
34 #include <type_traits>
35--
362.39.1
37
diff --git a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.8.bb
index 3a1eec8b1c..bea1f0b18c 100644
--- a/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.7.bb
+++ b/meta-oe/recipes-extended/redis-plus-plus/redis-plus-plus_1.3.8.bb
@@ -7,9 +7,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
7DEPENDS += "hiredis" 7DEPENDS += "hiredis"
8 8
9SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \ 9SRC_URI = "git://github.com/sewenew/redis-plus-plus;branch=master;protocol=https \
10 file://0001-include-cstdint.patch \
11 file://0001-CMakeLists.txt-fix-substitution-for-static-libs.patch" 10 file://0001-CMakeLists.txt-fix-substitution-for-static-libs.patch"
12SRCREV = "f3b19a8a1f609d1a1b79002802e5cf8c336dc262" 11SRCREV = "4368319fb668204f345da05b9dd79762506c67b6"
13 12
14S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
15 14