diff options
3 files changed, 47 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb index 6ca652e12d..e3ae050ec1 100644 --- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb +++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb | |||
@@ -436,6 +436,7 @@ RDEPENDS:packagegroup-meta-python3 = "\ | |||
436 | python3-typeguard \ | 436 | python3-typeguard \ |
437 | python3-tzlocal \ | 437 | python3-tzlocal \ |
438 | python3-u-msgpack-python \ | 438 | python3-u-msgpack-python \ |
439 | python3-uinput \ | ||
439 | python3-ujson \ | 440 | python3-ujson \ |
440 | python3-unidiff \ | 441 | python3-unidiff \ |
441 | python3-uritemplate \ | 442 | python3-uritemplate \ |
diff --git a/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch new file mode 100644 index 0000000000..54a3c18676 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 7a4dde83a9584adb42c7f810d882b1fbf5767e2c Mon Sep 17 00:00:00 2001 | ||
2 | From: Bartosz Golaszewski <brgl@bgdev.pl> | ||
3 | Date: Tue, 24 May 2022 21:43:35 +0200 | ||
4 | Subject: [PATCH] setup: use setuptools instead of distutils | ||
5 | |||
6 | The latter is deprecated, use setuptools instead. | ||
7 | |||
8 | Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> | ||
9 | --- | ||
10 | setup.py | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/setup.py b/setup.py | ||
14 | index 3fa3343..4900b8b 100644 | ||
15 | --- a/setup.py | ||
16 | +++ b/setup.py | ||
17 | @@ -3,7 +3,7 @@ | ||
18 | import errno | ||
19 | import subprocess | ||
20 | |||
21 | -from distutils.core import setup, Extension | ||
22 | +from setuptools import setup, Extension | ||
23 | |||
24 | libudev_so = "libudev.so.1" | ||
25 | |||
26 | -- | ||
27 | 2.34.1 | ||
28 | |||
diff --git a/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb b/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb new file mode 100644 index 0000000000..737bbfe2c8 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | SUMMARY = "Python interface to Linux uinput kernel module." | ||
2 | HOMEPAGE = "https://pypi.org/project/python-uinput/" | ||
3 | LICENSE = "GPL-3.0-only" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949" | ||
5 | |||
6 | SRC_URI[sha256sum] = "99392b676c77b5795b86b7d75274db33fe754fd1e06fb3d58b167c797dc47f0c" | ||
7 | SRC_URI += "file://0001-setup-use-setuptools-instead-of-distutils.patch" | ||
8 | |||
9 | PYPI_PACKAGE = "python-uinput" | ||
10 | |||
11 | inherit pypi setuptools3 | ||
12 | |||
13 | DEPENDS += "udev" | ||
14 | RDEPENDS:${PN} += " \ | ||
15 | python3-ctypes \ | ||
16 | python3-distutils \ | ||
17 | " | ||
18 | RRECOMMENDS:${PN} += "kernel-module-uinput" | ||