summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-24 21:46:42 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-26 18:54:39 -0700
commitdda4a40fcfdf2bcd8f95c49a2741f2e1df8f0102 (patch)
tree9c91d5575d5d55d0c468a7bb12094cff3d9db04c
parent03a1a24618e7366235af76ea58514442669f0a76 (diff)
downloadmeta-openembedded-dda4a40fcfdf2bcd8f95c49a2741f2e1df8f0102.tar.gz
python3-uinput: new package
Add a recipe for python3-uinput: a python module for controlling the virtual input devices on linux. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch28
-rw-r--r--meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb18
3 files changed, 47 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 6ca652e12..e3ae050ec 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -436,6 +436,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
436 python3-typeguard \ 436 python3-typeguard \
437 python3-tzlocal \ 437 python3-tzlocal \
438 python3-u-msgpack-python \ 438 python3-u-msgpack-python \
439 python3-uinput \
439 python3-ujson \ 440 python3-ujson \
440 python3-unidiff \ 441 python3-unidiff \
441 python3-uritemplate \ 442 python3-uritemplate \
diff --git a/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch
new file mode 100644
index 000000000..54a3c1867
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-uinput/0001-setup-use-setuptools-instead-of-distutils.patch
@@ -0,0 +1,28 @@
1From 7a4dde83a9584adb42c7f810d882b1fbf5767e2c Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <brgl@bgdev.pl>
3Date: Tue, 24 May 2022 21:43:35 +0200
4Subject: [PATCH] setup: use setuptools instead of distutils
5
6The latter is deprecated, use setuptools instead.
7
8Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
9---
10 setup.py | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/setup.py b/setup.py
14index 3fa3343..4900b8b 100644
15--- a/setup.py
16+++ b/setup.py
17@@ -3,7 +3,7 @@
18 import errno
19 import subprocess
20
21-from distutils.core import setup, Extension
22+from setuptools import setup, Extension
23
24 libudev_so = "libudev.so.1"
25
26--
272.34.1
28
diff --git a/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb b/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb
new file mode 100644
index 000000000..737bbfe2c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-uinput_0.11.2.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Python interface to Linux uinput kernel module."
2HOMEPAGE = "https://pypi.org/project/python-uinput/"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
5
6SRC_URI[sha256sum] = "99392b676c77b5795b86b7d75274db33fe754fd1e06fb3d58b167c797dc47f0c"
7SRC_URI += "file://0001-setup-use-setuptools-instead-of-distutils.patch"
8
9PYPI_PACKAGE = "python-uinput"
10
11inherit pypi setuptools3
12
13DEPENDS += "udev"
14RDEPENDS:${PN} += " \
15 python3-ctypes \
16 python3-distutils \
17"
18RRECOMMENDS:${PN} += "kernel-module-uinput"