summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick/0001-m4-Use-autconf-provided-AC_FUNC_FSEEKO.patch42
-rw-r--r--meta-oe/recipes-support/imagemagick/imagemagick_7.1.1.bb (renamed from meta-oe/recipes-support/imagemagick/imagemagick_7.0.10.bb)16
2 files changed, 52 insertions, 6 deletions
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick/0001-m4-Use-autconf-provided-AC_FUNC_FSEEKO.patch b/meta-oe/recipes-support/imagemagick/imagemagick/0001-m4-Use-autconf-provided-AC_FUNC_FSEEKO.patch
new file mode 100644
index 000000000..6b225a10c
--- /dev/null
+++ b/meta-oe/recipes-support/imagemagick/imagemagick/0001-m4-Use-autconf-provided-AC_FUNC_FSEEKO.patch
@@ -0,0 +1,42 @@
1From 0912e49d58c2a5f455fabf76ab7dc61cfc44cfb9 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 30 Mar 2023 20:50:26 -0700
4Subject: [PATCH] m4: Use autconf provided AC_FUNC_FSEEKO
5
6This helps in building with autoconf 2.72
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 m4/ac_func_fseeko.m4 | 18 +-----------------
12 1 file changed, 1 insertion(+), 17 deletions(-)
13
14diff --git a/m4/ac_func_fseeko.m4 b/m4/ac_func_fseeko.m4
15index eaeabb978..f9b8859cf 100644
16--- a/m4/ac_func_fseeko.m4
17+++ b/m4/ac_func_fseeko.m4
18@@ -53,20 +53,4 @@
19 # --------------
20 AN_FUNCTION([ftello], [AC_FUNC_FSEEKO])
21 AN_FUNCTION([fseeko], [AC_FUNC_FSEEKO])
22-AC_DEFUN([AC_FUNC_FSEEKO],
23-[_AC_SYS_LARGEFILE_MACRO_VALUE(_LARGEFILE_SOURCE, 1,
24- [ac_cv_sys_largefile_source],
25- [Define to 1 to make fseeko visible on some hosts (e.g. glibc 2.2).],
26- [[#include <sys/types.h> /* for off_t */
27- #include <stdio.h>]],
28- [[int (*fp) (FILE *, off_t, int) = fseeko;
29- return fseeko (stdin, 0, 0) && fp (stdin, 0, 0);]])
30-
31-# We used to try defining _XOPEN_SOURCE=500 too, to work around a bug
32-# in glibc 2.1.3, but that breaks too many other things.
33-# If you want fseeko and ftello with glibc, upgrade to a fixed glibc.
34-if test $ac_cv_sys_largefile_source != unknown; then
35- AC_DEFINE(HAVE_FSEEKO, 1,
36- [Define to 1 if fseeko (and presumably ftello) exists and is declared.])
37-fi
38-])# AC_FUNC_FSEEKO
39+AC_FUNC_FSEEKO
40--
412.40.0
42
diff --git a/meta-oe/recipes-support/imagemagick/imagemagick_7.0.10.bb b/meta-oe/recipes-support/imagemagick/imagemagick_7.1.1.bb
index b6344a381..07434c056 100644
--- a/meta-oe/recipes-support/imagemagick/imagemagick_7.0.10.bb
+++ b/meta-oe/recipes-support/imagemagick/imagemagick_7.1.1.bb
@@ -4,23 +4,27 @@ HOMEPAGE = "https://www.imagemagick.org/"
4DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \ 4DESCRIPTION = "ImageMagick is a collection of tools for displaying, converting, and \
5editing raster and vector image files. It can read and write over 200 image file formats." 5editing raster and vector image files. It can read and write over 200 image file formats."
6LICENSE = "ImageMagick" 6LICENSE = "ImageMagick"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=b97c12a9213df1499565d69b92c73dd7 \ 7LIC_FILES_CHKSUM = "file://LICENSE;md5=ac58ac14f9d9d02cafd2d81ef38fb2cc \
8 file://NOTICE;md5=d8b9d2ccf273687ad12ebd06e5d8478f" 8 file://NOTICE;md5=bcbf1f1897b40ec8df39700cb560e9ed"
9# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results. 9# FIXME: There are many more checked libraries. All should be added or explicitly disabled to get consistent results.
10DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool" 10DEPENDS = "lcms bzip2 jpeg libpng tiff zlib fftw freetype libtool"
11 11
12BASE_PV := "${PV}" 12BASE_PV := "${PV}"
13PV .= "-62" 13PV .= "-5"
14SRC_URI = "git://github.com/ImageMagick/ImageMagick.git;branch=main;protocol=https" 14SRC_URI = "git://github.com/ImageMagick/ImageMagick.git;branch=main;protocol=https \
15SRCREV = "35b4991eb0939a327f3489988c366e21068b0178" 15 file://0001-m4-Use-autconf-provided-AC_FUNC_FSEEKO.patch"
16SRCREV = "2d24be538f286962c355cf422bb525375ac77998"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
18 19
19inherit autotools pkgconfig update-alternatives 20inherit autotools pkgconfig update-alternatives
21export ac_cv_sys_file_offset_bits="64"
20 22
21# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2 23# xml disabled because it's using xml2-config --prefix to determine prefix which returns just /usr with our libxml2
22# if someone needs xml support then fix it first 24# if someone needs xml support then fix it first
23EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl --disable-openmp --without-xml --disable-opencl" 25EXTRA_OECONF = "--program-prefix= --program-suffix=.im7 --without-perl \
26 --disable-openmp --without-xml --disable-opencl \
27 --enable-largefile"
24 28
25PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" 29PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}"
26PACKAGECONFIG[cxx] = "--with-magick-plus-plus,--without-magick-plus-plus" 30PACKAGECONFIG[cxx] = "--with-magick-plus-plus,--without-magick-plus-plus"