diff options
-rw-r--r-- | meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch | 49 | ||||
-rw-r--r-- | meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb | 1 |
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch b/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch new file mode 100644 index 000000000..b6211c28a --- /dev/null +++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr/0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch | |||
@@ -0,0 +1,49 @@ | |||
1 | From a9f8d414972b0b7c963d7efe38b5cfdcb6413c46 Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Jones <pjones@redhat.com> | ||
3 | Date: Mon, 6 Feb 2017 16:34:54 -0500 | ||
4 | Subject: [PATCH] Remove extra const keywords gcc 7 gripes about. | ||
5 | |||
6 | Signed-off-by: Peter Jones <pjones@redhat.com> | ||
7 | --- | ||
8 | src/efibootdump.c | 2 +- | ||
9 | src/efibootmgr.c | 4 ++-- | ||
10 | 2 files changed, 3 insertions(+), 3 deletions(-) | ||
11 | |||
12 | diff --git a/src/efibootdump.c b/src/efibootdump.c | ||
13 | index 3e448c2..5a9b681 100644 | ||
14 | --- a/src/efibootdump.c | ||
15 | +++ b/src/efibootdump.c | ||
16 | @@ -36,7 +36,7 @@ print_boot_entry(efi_load_option *loadopt, size_t data_size) | ||
17 | uint8_t *optional_data = NULL; | ||
18 | size_t optional_data_len = 0; | ||
19 | uint16_t pathlen; | ||
20 | - const unsigned char const *desc; | ||
21 | + const unsigned char *desc; | ||
22 | char *raw; | ||
23 | size_t raw_len; | ||
24 | |||
25 | diff --git a/src/efibootmgr.c b/src/efibootmgr.c | ||
26 | index baefa68..683623b 100644 | ||
27 | --- a/src/efibootmgr.c | ||
28 | +++ b/src/efibootmgr.c | ||
29 | @@ -214,7 +214,7 @@ warn_duplicate_name(list_t *boot_list) | ||
30 | list_t *pos; | ||
31 | var_entry_t *boot; | ||
32 | efi_load_option *load_option; | ||
33 | - const unsigned char const *desc; | ||
34 | + const unsigned char *desc; | ||
35 | |||
36 | list_for_each(pos, boot_list) { | ||
37 | boot = list_entry(pos, var_entry_t, list); | ||
38 | @@ -821,7 +821,7 @@ show_boot_vars() | ||
39 | { | ||
40 | list_t *pos; | ||
41 | var_entry_t *boot; | ||
42 | - const unsigned char const *description; | ||
43 | + const unsigned char *description; | ||
44 | efi_load_option *load_option; | ||
45 | efidp dp = NULL; | ||
46 | unsigned char *optional_data = NULL; | ||
47 | -- | ||
48 | 2.12.2 | ||
49 | |||
diff --git a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb index b25cfcabd..193150bb9 100644 --- a/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb +++ b/meta-oe/recipes-extended/efibootmgr/efibootmgr_0.12.bb | |||
@@ -12,6 +12,7 @@ COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | |||
12 | 12 | ||
13 | SRCREV = "75d25807ba81cb724964c989012611272c8f1f5d" | 13 | SRCREV = "75d25807ba81cb724964c989012611272c8f1f5d" |
14 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \ | 14 | SRC_URI = "git://github.com/rhinstaller/efibootmgr.git;protocol=https \ |
15 | file://0001-Remove-extra-const-keywords-gcc-7-gripes-about.patch \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | S = "${WORKDIR}/git" | 18 | S = "${WORKDIR}/git" |